[bug#77814,2/5] gnu: Add font-koruri.

Message ID 20250415030423.16454-2-hunt31999@gmail.com
State New
Headers
Series gnu: Add Japanese fonts |

Commit Message

Kurome April 15, 2025, 3:04 a.m. UTC
  * gnu/packages/fonts.scm (font-koruri): New variable.

Change-Id: I6a2db34eb140b8d4cf5bf4341a33b43f96d85b81
---
 gnu/packages/fonts.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)
  

Patch

diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index 8c631c68aa..6199959000 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -3515,6 +3515,30 @@  (define-public font-takao
 assurance are essential.")
     (license license:ipa)))
 
+(define-public font-koruri
+  ;; Source: https://github.com/Koruri/Scripts
+  (package
+    (name "font-koruri")
+    (version "20210720")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/Koruri/Koruri")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0yadd6rcyf940c441zr1m90srhz9xjsak281bvn6p6br7nsm9gyc"))))
+    (build-system font-build-system)
+    (home-page "https://koruri.github.io/")
+    (synopsis "Japanese TrueType font obtained by mixing M+ FONTS and Open Sans")
+    (description
+     "This package provides the Koruri font, a Japanese TrueType font composed
+of Open Sans and OSDN’s M+ 1p.  It is designed with an emphasis on readability
+in texts containing mixed alphanumeric characters and in user interfaces of
+computer software.")
+    (license license:asl2.0)))
+
 (define-public font-catamaran
   (let ((commit "7559b4906f9c9148fb22c6f89508c3053a78a296")
         (revision "1"))