[bug#77726,v2] gnu: Add emacs-smooth-scroll.

Message ID 20250413014203.21926-1-hunt31999@gmail.com
State New
Headers
Series [bug#77726,v2] gnu: Add emacs-smooth-scroll. |

Commit Message

Kurome April 13, 2025, 1:41 a.m. UTC
  * gnu/packages/emacs-xyz.scm (emacs-smooth-scroll): New variable.

Change-Id: I81c89e40a89acac94f0e5611b312eb88056cd4b3
---
 gnu/packages/emacs-xyz.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)
  

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 421b9b4cfa..575bf56c07 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -29244,6 +29244,27 @@  (define-public emacs-git-auto-commit-mode
 current upstream.")
     (license license:gpl3+)))
 
+(define-public emacs-smooth-scroll
+  (package
+    (name "emacs-smooth-scroll")
+    (version "1.3")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/k-talo/smooth-scroll.el")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0d2qzpgh486cp0aa12ky1np1i49d0gskvldfw627v55qsm6ql9ll"))))
+    (build-system emacs-build-system)
+    (arguments (list #:tests? #f))      ; no tests
+    (home-page "https://github.com/k-talo/smooth-scroll.el")
+    (synopsis "Minor mode for smooth and in-place scrolling in Emacs")
+    (description "This package provides the @code{smooth-scroll-mode} minor mode
+ for Emacs, enabling smooth and in-place scrolling functionality.")
+    (license license:gpl3+)))
+
 (define-public emacs-scroll-on-drag
   (let ((commit "179c2acecc48d3ceca4b449b2a225d684002bb32")
         (revision "2"))