[bug#77729,v2] gnu: Add emacs-affe.

Message ID 20250413013926.21033-2-hunt31999@gmail.com
State New
Headers
Series [bug#77729,v2] gnu: Add emacs-affe. |

Commit Message

Kurome April 13, 2025, 1:38 a.m. UTC
  * gnu/packages/emacs-xyz.scm (emacs-affe): New variable.

Change-Id: Iec76bcf2a489830dfd352c80e00f8870a29fe386
---
 gnu/packages/emacs-xyz.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)
  

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 421b9b4cfa..35f1f0818c 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -2205,6 +2205,31 @@  (define-public emacs-meyvn
        "This package provides an Emacs client for the @url{https://meyvn.org, Meyvn} build tool.")
       (license license:gpl3+))))
 
+(define-public emacs-affe
+  (package
+    (name "emacs-affe")
+    (version "0.9")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/minad/affe")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "166v7d120hbk6vczj1iam85xivk6wwpvga8m0vxgcii19issh5b3"))))
+    (build-system emacs-build-system)
+    (arguments (list #:tests? #f))      ; no tests
+    (propagated-inputs (list emacs-consult))
+    (home-page "https://github.com/minad/affe")
+    (synopsis "Asynchronous fuzzy finder for Emacs")
+    (description "This package provides Affe, an asynchronous fuzzy finder for
+GNU Emacs written in pure Emacs Lisp. It spawns an external producer process,
+such as @command{find} or @command{grep}, and filters the output asynchronously.
+The UI remains responsive, and results are shown via the Consult interface.
+Affe is experimental and best suited for small to medium projects.")
+    (license license:gpl3+)))
+
 (define-public emacs-fzf
   (let ((commit "21912ebc7e1084aa88c9d8b7715e782a3978ed23")
         (revision "0"))