[bug#77728] gnu: Add emacs-outli.

Message ID 20250411082812.6633-1-hunt31999@gmail.com
State New
Headers
Series [bug#77728] gnu: Add emacs-outli. |

Commit Message

Kurome April 11, 2025, 8:27 a.m. UTC
  * gnu/packages/emacs-xyz.scm (emacs-outli): New variable.

Change-Id: If1a082000f8105829ca9e0ecbedee1da4201bf40
---
 gnu/packages/emacs-xyz.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)
  

Comments

Cayetano Santos April 12, 2025, 5:04 p.m. UTC | #1
+    (build-system emacs-build-system)

Could you please explicitly disable the tests ?

    (arguments (list #:tests? #f))      ; no tests

This becomes mandatory in case there are no tests in the package.

Thanks !

C.
  
Kurome April 13, 2025, 6:37 a.m. UTC | #2
OK. Thanks!

I did the same for #77726 and #77728.
  

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 421b9b4cfa..8579cfd246 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -157,6 +157,7 @@ 
 ;;; Copyright © 2025 Cayetano Santos <csantosb@inventati.org>
 ;;; Copyright © 2025 Lee Thompson <lee.p.thomp@gmail.com>
 ;;; Copyright @ 2025 Amy Pillow <amypillow@lavache.com>
+;;; Copyright © 2025 Kurome <hunt31999@gmail.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -25776,6 +25777,31 @@  (define-public emacs-outorg
 text-mode (i.e. Org-mode).")
       (license license:gpl3+))))
 
+(define-public emacs-outli
+  (package
+    (name "emacs-outli")
+    (version "0.2.3")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/jdtsmith/outli")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "01q37gbfc0mal3ha2x5a1axdcd2c0d55imav4w0cfzs3sm48azvs"))))
+    (build-system emacs-build-system)
+    (home-page "https://github.com/jdtsmith/outli")
+    (synopsis "Simple and stylish comment-based outliner for Emacs")
+    (description "This package provides @code{outli-mode}, a minimal and elegant
+outliner for Emacs that enhances @code{outline-minor-mode} with configurable
+heading syntax, styled headings, and org-mode-inspired navigation and structure
+editing.  It supports comment-based headers with customizable stems and repeat
+characters, styled overlines and backgrounds, tab-based visibility toggling,
+org-style speed keys for headline manipulation, and imenu integration for fast
+navigation.")
+    (license license:gpl3+)))
+
 (define-public emacs-outshine
   (let ((commit "bf1eed10dd7a89b63d0fc014944033db397c1e23")
         (revision "1"))