[bug#77700] gnu: python-iso8601: Update to 2.1.0.

Message ID 20250410125222.21281-1-dziltener@lyrion.ch
State New
Headers
Series [bug#77700] gnu: python-iso8601: Update to 2.1.0. |

Commit Message

Daniel Ziltener April 10, 2025, 12:52 p.m. UTC
  ---
 gnu/packages/time.scm | 20 +++++++++-----------
 1 file changed, 9 insertions(+), 11 deletions(-)
  

Patch

diff --git a/gnu/packages/time.scm b/gnu/packages/time.scm
index 56053da501..74fd4dba6a 100644
--- a/gnu/packages/time.scm
+++ b/gnu/packages/time.scm
@@ -515,28 +515,26 @@  (define-public python-isodate
 (define-public python-iso8601
   (package
     (name "python-iso8601")
-    (version "1.0.2")
+    (version "2.1.0")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "iso8601" version))
        (sha256
-        (base32
-         "1ccl6plks706hxm35cn1wsvxhqh3bfwi5cjgjpdxjib81qi07x97"))))
-    (build-system python-build-system)
+        (base32 "1px83gnklx1dmwb3n3dcplyfvaczhbvhkjcq34qc88c9xqlkh7bb"))))
+    (build-system pyproject-build-system)
     (arguments
      '(#:phases (modify-phases %standard-phases
                   (replace 'check
                     (lambda _
                       (invoke "pytest" "-vv" "iso8601"))))))
-    (native-inputs
-     (list python-pytest python-pytz))
+    (native-inputs (list python-pytest
+                         python-poetry-core
+                         python-pytz))
     (home-page "https://github.com/micktwomey/pyiso8601")
-    (synopsis "Module to parse ISO 8601 dates")
-    (description
-     "This module parses the most common forms of ISO 8601 date strings (e.g.
-@code{2007-01-14T20:34:22+00:00}) into @code{datetime} objects.")
-    (license expat)))
+    (synopsis "Simple module to parse ISO 8601 dates")
+    (description "Simple module to parse ISO 8601 dates.")
+    (license license:expat)))
 
 (define-public python-monotonic
   (package