[bug#77699] gnu: python-web: Add python-quart-trio 0.12.0.

Message ID 20250410125129.20616-1-dziltener@lyrion.ch
State New
Headers
Series [bug#77699] gnu: python-web: Add python-quart-trio 0.12.0. |

Commit Message

Daniel Ziltener April 10, 2025, 12:51 p.m. UTC
  ---
 gnu/packages/python-web.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)
  

Comments

Sharlatan Hellseher April 13, 2025, 8:12 p.m. UTC | #1
Hi,

Thank you for the patch.

I've enabled tests and adjust descriptions:
--8<---------------cut here---------------start------------->8---
modified   gnu/packages/python-web.scm
@@ -9958,15 +9958,28 @@ (define-public python-quart-trio
     (build-system pyproject-build-system)
     (arguments
      (list
-      #:tests? #f))
-    (propagated-inputs (list python-exceptiongroup python-hypercorn
-                             python-pydata-sphinx-theme python-quart
-                             python-trio))
-    (native-inputs (list python-pdm-backend))
-    (home-page #f)
-    (synopsis "A Quart extension to provide trio support")
-    (description
-     "This package provides a Quart extension to provide trio support.")
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-after 'unpack 'remove-coverage-pytest-options
+            (lambda _
+              (substitute* "pyproject.toml"
+                (("--no-cov-on-fail") "")))))))
+    (native-inputs
+     (list python-pdm-backend
+           python-pytest
+           python-pytest-sugar
+           python-pytest-trio))
+    (propagated-inputs
+     (list python-exceptiongroup
+           python-hypercorn
+           python-quart
+           python-trio))
+    (home-page "https://github.com/pgjones/quart-trio")
+    (synopsis "Extension for Quart to support the Trio event loop")
+    (description
+     "This package provides a Quart extension to provide Trio support.  This
+is an alternative to using the asyncio event loop present in the Python
+standard library and supported by default in Quart.")
     (license license:expat))))
--8<---------------cut here---------------end--------------->8---

Pushed to master as f0e0caa570681a29be34ca5a5c634da22a7c4099.

--
Oleg
  

Patch

diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 035c399a68..1deb392c5e 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -9945,6 +9945,30 @@  (define-public python-quart
 as Flask.")
     (license license:expat)))
 
+(define-public python-quart-trio
+  (package
+    (name "python-quart-trio")
+    (version "0.12.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "quart_trio" version))
+       (sha256
+        (base32 "130r8hdk7xxjp380z1r3m28lw86q2a6g9rf0mgp9gs6hk04q9v02"))))
+    (build-system pyproject-build-system)
+    (arguments
+     (list
+      #:tests? #f))
+    (propagated-inputs (list python-exceptiongroup python-hypercorn
+                             python-pydata-sphinx-theme python-quart
+                             python-trio))
+    (native-inputs (list python-pdm-backend))
+    (home-page #f)
+    (synopsis "A Quart extension to provide trio support")
+    (description
+     "This package provides a Quart extension to provide trio support.")
+    (license license:expat)))
+
 (define-public python-ajsonrpc
   (package
     (name "python-ajsonrpc")