[bug#77698,7/7] gnu: python-trio: Update to 0.29.0.
Commit Message
---
gnu/packages/python-xyz.scm | 20 ++++++++++----------
1 file changed, 10 insertions(+), 10 deletions(-)
@@ -31475,13 +31475,13 @@ (define-public python-outcome
(define-public python-trio
(package
(name "python-trio")
- (version "0.28.0")
+ (version "0.29.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "trio" version))
(sha256
- (base32 "019wqwlbj185skknbjd7paxqqx6vl5gpqk2fwmc5d2lyzsb7hm2f"))))
+ (base32 "1pqv6s6b19lkr3nfwpbbwbz69qsqwph0p6lknsn31hcz2mkkj3ga"))))
(build-system pyproject-build-system)
(arguments
(list
@@ -31505,6 +31505,7 @@ (define-public python-trio
" and not test_locals_destroyed_promptly_on_cancel"
" and not test_ipython_exc_handler"
" and not test_for_leaking_fds"
+ " and not test_testing_raisesgroup"
;; Signals don’t work in the build sandbox.
" and not test_open_signal_receiver"
;; These try to raise KeyboardInterrupt which does not work
@@ -31538,6 +31539,13 @@ (define-public python-trio
(setenv "HOME" "/tmp")
;; #$output is first in path which causes "import file mismatch"
(setenv "PYTHONPATH" (string-append (getcwd) "/src:$PYTHONPATH")))))))
+ (propagated-inputs (list python-attrs
+ python-cffi
+ python-exceptiongroup
+ python-idna
+ python-outcome
+ python-sniffio
+ python-sortedcontainers))
(native-inputs
(append
(if (supported-package? python-pyopenssl)
@@ -31549,14 +31557,6 @@ (define-public python-trio
(list python-trustme)
'())
(list python-wheel)))
- (propagated-inputs
- (list python-attrs
- python-cffi
- python-exceptiongroup
- python-idna
- python-outcome
- python-sniffio
- python-sortedcontainers))
(home-page "https://github.com/python-trio/trio")
(synopsis "Friendly Python library for async concurrency and I/O")
(description