[bug#77698,5/7] gnu: python-netaddr: Update to 1.3.0.

Message ID 20250410122657.9705-6-dziltener@lyrion.ch
State New
Headers
Series Updates for a bunch of Python libraries |

Commit Message

Daniel Ziltener April 10, 2025, 12:26 p.m. UTC
  ---
 gnu/packages/python-xyz.scm | 10 ++++++----
 1 file changed, 6 insertions(+), 4 deletions(-)
  

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 0cec18b823..a78bd02d93 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -17416,16 +17416,18 @@  (define-public python-msgpack-transitional
 (define-public python-netaddr
   (package
     (name "python-netaddr")
-    (version "0.8.0")
+    (version "1.3.0")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "netaddr" version))
        (sha256
-         (base32
-          "0hx2npi0wnhwlcybilgwlddw6qffx1mb7a3sj4p9s7bvl33mgk6n"))))
-    (build-system python-build-system)
+        (base32 "12p4ysgawhgkka0sz1dkwgwc2za80dxdp9wvfxivfldmjnc3sg2w"))))
+    (build-system pyproject-build-system)
     (arguments `(#:tests? #f)) ;; No tests.
+    (native-inputs (list python-poetry-core
+                         python-setuptools
+                         python-wheel))
     (home-page "https://github.com/drkjam/netaddr/")
     (synopsis "Pythonic manipulation of  network addresses")
     (description