[bug#77698,4/7] gnu: python-stestr: Update to 4.1.0.

Message ID 20250410122657.9705-5-dziltener@lyrion.ch
State New
Headers
Series Updates for a bunch of Python libraries |

Commit Message

Daniel Ziltener April 10, 2025, 12:26 p.m. UTC
  ---
 gnu/packages/python-check.scm | 35 +++++++++++++++++++++--------------
 1 file changed, 21 insertions(+), 14 deletions(-)
  

Patch

diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 4718044240..0defa85a05 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -2779,27 +2779,34 @@  (define-public python-slotscheck
 (define-public python-stestr
   (package
     (name "python-stestr")
-    (version "3.2.1")
+    (version "4.1.0")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "stestr" version))
        (sha256
-        (base32
-         "1kg9gfdr4bj2m7s1r44z530a0ba4p17j4jlhcn1xha0j8jmyfgn2"))))
-    (build-system python-build-system)
+        (base32 "12p96kzanzzssr6z4hq6k62pdbsql4mf369ms69c4qyfxrlw6qaz"))))
+    (build-system pyproject-build-system)
     (arguments
      `(#:tests? #f))                    ;to avoid circular dependencies
-    (native-inputs
-     (list python-pbr))
-    (propagated-inputs
-     (list python-cliff
-           python-fixtures
-           python-future
-           python-pyyaml
-           python-subunit
-           python-testtools
-           python-voluptuous))
+    (propagated-inputs (list python-cliff
+                             python-extras
+                             python-fixtures
+                             python-pbr
+                             python-subunit
+                             python-pyyaml
+                             python-testtools
+                             python-tomlkit
+                             python-voluptuous))
+    (native-inputs (list python-black
+                         python-coverage
+                         python-ddt
+                         python-doc8
+                         python-hacking
+                         python-iso8601
+                         python-setuptools
+                         python-sphinx
+                         python-wheel))
     (home-page "https://stestr.readthedocs.io/en/latest/")
     (synopsis "Parallel Python test runner")
     (description "This package provides the @command{stestr} command, a