[bug#77698,1/7] gnu: python-wheel: Update to 0.45.1.

Message ID 20250410122657.9705-2-dziltener@lyrion.ch
State New
Headers
Series Updates for a bunch of Python libraries |

Commit Message

Daniel Ziltener April 10, 2025, 12:26 p.m. UTC
  ---
 gnu/packages/python-build.scm | 17 ++++++++---------
 1 file changed, 8 insertions(+), 9 deletions(-)
  

Patch

diff --git a/gnu/packages/python-build.scm b/gnu/packages/python-build.scm
index 375896a76a..5d2c01bf62 100644
--- a/gnu/packages/python-build.scm
+++ b/gnu/packages/python-build.scm
@@ -359,20 +359,20 @@  (define-public python-setuptools-57
 (define-public python-wheel
   (package
     (name "python-wheel")
-    (version "0.40.0")
+    (version "0.45.1")
     (source
-      (origin
-        (method url-fetch)
-        (uri (pypi-uri "wheel" version))
-        (sha256
-         (base32
-          "0ww8fgkvwv35ypj4cnngczdwp6agr4qifvk2inb32azfzbrrc4fd"))))
-    (build-system python-build-system)
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "wheel" version))
+       (sha256
+        (base32 "0ab7ramncrii43smhvcidrbv4w4ndl80435214a7nl4qj6yil7k6"))))
+    (build-system pyproject-build-system)
     (arguments
      ;; FIXME: The test suite runs "python setup.py bdist_wheel", which in turn
      ;; fails to find the newly-built bdist_wheel library, even though it is
      ;; available on PYTHONPATH.  What search path is consulted by setup.py?
      '(#:tests? #f))
+    (native-inputs (list python-flit-core))
     (home-page "https://github.com/pypa/wheel")
     (synopsis "Format for built Python packages")
     (description
@@ -881,4 +881,3 @@  (define-public python-pdm-backend
      "PDM-Backend is a build backend that supports the latest packaging
 standards, which includes PEP 517, PEP 621 and PEP 660.")
     (license license:expat)))
-