[bug#77689] gnu: libfilezilla: Update source origin.
Commit Message
* gnu/packages/ftp.scm (gnu): (libfilezilla): Update source origin.
[source]: Replace `url-fetch` with `svn-fetch`.
[native-inputs]: Add `automake`, `autoconf` and `libtool`.
---
gnu/packages/ftp.scm | 55 ++++++++++++++++++++++++++------------------
1 file changed, 33 insertions(+), 22 deletions(-)
@@ -29,6 +29,7 @@ (define-module (gnu packages ftp)
#:use-module (guix download)
#:use-module (guix gexp)
#:use-module (guix git-download)
+ #:use-module (guix svn-download)
#:use-module (guix packages)
#:use-module (guix utils)
#:use-module (gnu packages)
@@ -203,28 +204,38 @@ (define-public weex
(license gpl2+)))
(define-public libfilezilla
- (package
- (name "libfilezilla")
- (version "0.39.2")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "https://download.filezilla-project.org/"
- "libfilezilla/libfilezilla-" version ".tar.bz2"))
- (sha256
- (base32 "1x2rixppmvdpn9m01hmh3yqzpczxbkw301hx27n5bfq0dbnx9aar"))))
- (build-system gnu-build-system)
- (arguments
- `(#:configure-flags
+ (let ((revision 10763))
+ (package
+ (name "libfilezilla")
+ (version "0.39.2")
+ (source
+ (origin
+ (method svn-fetch)
+ (uri (svn-reference
+ (url "https://svn.filezilla-project.org/svn/libfilezilla/trunk")
+ (revision revision)))
+ (file-name (string-append name "-" version "-" (number->string revision)))
+ (sha256
+ (base32 "0x7lx8474xcqgp181kg8bw5c10nxd19hw8lhxa5fkry50mfqyzmj"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:configure-flags
(list "--disable-static")))
- (native-inputs
- (list cppunit gettext-minimal libxcrypt pkg-config))
- (inputs
- (list gnutls nettle))
- (home-page "https://lib.filezilla-project.org")
- (synopsis "Cross-platform C++ library used by Filezilla client")
- (description
- "This package provides some basic functionality to build high-performing,
+ (native-inputs
+ (list
+ cppunit
+ gettext-minimal
+ libxcrypt
+ pkg-config
+ autoconf
+ automake
+ libtool))
+ (inputs
+ (list gnutls nettle))
+ (home-page "https://lib.filezilla-project.org")
+ (synopsis "Cross-platform C++ library used by Filezilla client")
+ (description
+ "This package provides some basic functionality to build high-performing,
platform-independent programs.
Some of the highlights include:
@@ -240,7 +251,7 @@ (define-public libfilezilla
Simple process handling for spawning child processes with redirected input and
output.
@end itemize\n")
- (license gpl2+)))
+ (license gpl2+))))
(define-public filezilla
(package