[bug#77660,1/5] gnu: go-codeberg-org-emersion-go-scfg: Update to 0.1.0.
Commit Message
---
gnu/packages/golang-xyz.scm | 16 ++++++++--------
gnu/packages/irc.scm | 3 +--
gnu/packages/messaging.scm | 2 +-
gnu/packages/version-control.scm | 2 +-
4 files changed, 11 insertions(+), 12 deletions(-)
@@ -375,25 +375,25 @@ (define-public go-dario-cat-mergo
maps (because they are not addressable using Go reflection).")
(license license:bsd-3)))
-(define-public go-git-sr-ht-emersion-go-scfg
+(define-public go-codeberg-org-emersion-go-scfg
(package
- (name "go-git-sr-ht-emersion-go-scfg")
- (version "0.0.0-20240128091534-2ae16e782082")
+ (name "go-codeberg-org-emersion-go-scfg")
+ (version "0.1.0")
(source
(origin
(method git-fetch)
(uri (git-reference
- (url "https://git.sr.ht/~emersion/go-scfg")
- (commit (go-version->git-ref version))))
+ (url "https://codeberg.org/emersion/go-scfg")
+ (commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1gxhg40q4md3lj1wrrnms0jhyqsxhx2hcv6sm5yjbbqana5x26mx"))))
+ (base32 "0yw35rf6cxk5cwzf9y4qd0rlcryq1pxr9n34q6620i9djhgskwq2"))))
(build-system go-build-system)
(arguments
- (list #:import-path "git.sr.ht/~emersion/go-scfg"))
+ (list #:import-path "codeberg.org/emersion/go-scfg"))
(propagated-inputs
(list go-github-com-davecgh-go-spew))
- (home-page "https://git.sr.ht/~emersion/go-scfg")
+ (home-page "https://codeberg.org/emersion/go-scfg")
(synopsis "Go library for simple configuration file format")
(description
"Package go-scfg parses scfg files.")
@@ -1259,7 +1259,7 @@ (define-public soju
(setenv "PREFIX" #$output)
(invoke "make" "install")))))))
(native-inputs
- (list go-git-sr-ht-emersion-go-scfg
+ (list go-codeberg-org-emersion-go-scfg
go-git-sr-ht-emersion-go-sqlite3-fts5
go-git-sr-ht-sircmpwn-go-bare
go-github-com-coder-websocket
@@ -1284,4 +1284,3 @@ (define-public soju
chat history playback and detached channels. It is well-suited for both small
and large deployments.")
(license license:agpl3)))
-
@@ -3729,7 +3729,7 @@ (define-public senpai
(string-append "src/" unpack-path "/doc/senpai.5")
man5)))))))
(native-inputs
- (list go-git-sr-ht-emersion-go-scfg
+ (list go-codeberg-org-emersion-go-scfg
go-github-com-delthas-go-libnp
go-github-com-delthas-go-localeinfo
go-github-com-delthas-tcell-v2 ; remove in the next release
@@ -4740,7 +4740,7 @@ (define-public hut
(native-inputs
(list scdoc))
(inputs
- (list go-git-sr-ht-emersion-go-scfg
+ (list go-codeberg-org-emersion-go-scfg
go-git-sr-ht-emersion-gqlclient
go-github-com-dustin-go-humanize
go-github-com-google-shlex