[bug#77234,v3,2/3] gnu: Add fcitx5-nord-theme.

Message ID 20250408025333.13586-2-hunt31999@gmail.com
State New
Headers
Series [bug#77234,v3,1/3] gnu: Add my-fcitx5-catppuccin-theme. |

Commit Message

Kurome April 8, 2025, 2:53 a.m. UTC
  * gnu/packages/fcitx5.scm (fcitx5-nord-theme): New variable.

Change-Id: I68ab31251d4b06a4228d50fa31b43f525866df4c
---
 gnu/packages/fcitx5.scm | 29 +++++++++++++++++++++++++++++
 1 file changed, 29 insertions(+)
  

Patch

diff --git a/gnu/packages/fcitx5.scm b/gnu/packages/fcitx5.scm
index 2044625c81..cdd63e0401 100644
--- a/gnu/packages/fcitx5.scm
+++ b/gnu/packages/fcitx5.scm
@@ -647,3 +647,32 @@  (define-public fcitx5-catppuccin-theme
 (rosewater, flamingo, pink, mauve, red, maroon, peach, yellow, green, teal, sky,
 sapphire, blue and lavender).")
       (license license:expat))))
+
+(define-public fcitx5-nord-theme
+  (let ((commit "bdaa8fb723b8d0b22f237c9a60195c5f9c9d74d1")
+        (revision "0"))
+    (package
+      (name "fcitx5-nord-theme")
+      (version (git-version "0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/tonyfettes/fcitx5-nord")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "04bjxzx26x9r01ss7l0fam22nhsvh38dpijy7za0grnr5g93ynm9"))))
+      (build-system copy-build-system)
+      (arguments
+       (list
+        #:install-plan
+        #~'(("Nord-Dark" "share/fcitx5/themes/")
+            ("Nord-Light" "share/fcitx5/themes/"))))
+      (home-page "https://github.com/tonyfettes/fcitx5-nord")
+      (synopsis "Fcitx5 theme based on Nord color")
+      (description
+       "Fcitx5-nord-theme is a Fcitx 5 theme based on Nord Color, featuring
+dimmed pastel colors for a comfortable yet vibrant ambiance.  It offers 2
+versions: Nord-dark and Nord-light.")
+      (license license:expat))))