[bug#77601,v2,1/2] gnu: font-fira-sans: Update to 4.301-1.f54eeb3

Message ID 20250407145623.23892-1-hunt31999@gmail.com
State New
Headers
Series [bug#77601,v2,1/2] gnu: font-fira-sans: Update to 4.301-1.f54eeb3 |

Commit Message

Kurome April 7, 2025, 2:55 p.m. UTC
  The former comment mentioned that this is the final version including the
source code.  However, many fonts included in Guix do not come with source
code, so I believe this is acceptable.

* gnu/packages/fonts.scm (font-fira-sans): Update to 4.301-1.f54eeb3.  Add
revision number.
[version]: Use git-version.
[arguments]: Use G-Expression.
<#:phases>: Modify 'enter-license-directory because the license
directory has changed.

Change-Id: Ib8e2a4fc194cf1886e0679c0824684700f4e728e
---
 gnu/packages/fonts.scm | 92 +++++++++++++++++++++---------------------
 1 file changed, 45 insertions(+), 47 deletions(-)
  

Patch

diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index 75b1bee6e2..33456697cd 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -1664,11 +1664,6 @@  (define-public font-microsoft-cascadia
     (license license:silofl1.1)))
 
 (define-public font-fira-sans
-  ;; Fira Sans v4.203 (which corresponds to Fira Mono v3.206) is the final
-  ;; version to include UFO sources. It is the same version packaged by other
-  ;; notable distributors, including Google Fonts. Note that the "reserved
-  ;; font name" was removed by the copyright holders.
-  ;;
   ;; The upstream release includes a "Fira Code" which "is Fira Mono 3.206
   ;; with less Line Space (1.0) – does not include programming ligatures". We
   ;; do not package that: our 'font-fira-code' package (like e.g. Debian's
@@ -1683,48 +1678,51 @@  (define-public font-fira-sans
   ;; See also:
   ;;   - https://github.com/mozilla/Fira/pull/219
   ;;   - https://github.com/bBoxType/FiraSans/issues/4#issuecomment-695833327
-  (package
-    (name "font-fira-sans")
-    (version "4.203")
-    (source (origin
-              (method git-fetch)
-              (uri (git-reference
-                     (url "https://github.com/bBoxType/FiraSans")
-                     (commit "a606927401bcc3951587339fee53aa882856b51b")))
-              (file-name (git-file-name name version))
-              (sha256
-               (base32
-                "1r9kb7v9jg83nnxwkl6gx9ix1rng3ksr7v33qrm46qb4fhwsyc2n"))))
-    (build-system font-build-system)
-    (arguments
-     `(#:modules
-       ((ice-9 match)
-        (ice-9 regex)
-        (guix build utils)
-        (guix build font-build-system))
-       #:phases
-       (modify-phases %standard-phases
-         (add-after 'unpack 'chdir
-           (lambda* (#:key outputs #:allow-other-keys)
-             (define-values (pkg-name _version)
-               (package-name->name+version
-                (strip-store-file-name (assoc-ref outputs "out"))))
-             (define variant
-               (string-capitalize
-                (match:substring (string-match "fira-([a-z]+)" pkg-name) 1)))
-             (match (find-files "." (format #f "^Fira_~a_[0-9]" variant)
-                                #:directories? #t)
-               ((dir)
-                (chdir dir)))))
-         (add-before 'install-license-files 'enter-license-directory
-           (lambda _
-             (chdir "../OFL_Licence"))))))
-    ;; While the repository has moved,
-    ;; this specimen still works well as the home-page:
-    (home-page "https://mozilla.github.io/Fira/")
-    (synopsis
-     "Humanist sans-serif with numerous weights emphasizing legibility")
-    (description "Fira Sans is a humanist sans-serif typeface with an emphasis
+  (let ((commit "f54eeb3124c63fe9b5bcd36d09d1cd46788cd15e")
+        (revision "1"))
+    (package
+      (name "font-fira-sans")
+      (version (git-version "4.301" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/bBoxType/FiraSans")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "1081x67dbmm2x4ckq67a8d6ia209x6jp70swl4w9v9nl1ci03jn3"))))
+      (build-system font-build-system)
+      (arguments
+       (list
+        #:modules
+        '((ice-9 match)
+          (ice-9 regex)
+          (guix build utils)
+          (guix build font-build-system))
+        #:phases
+        #~(modify-phases %standard-phases
+            (add-after 'unpack 'chdir
+              (lambda* (#:key outputs #:allow-other-keys)
+                (define-values (pkg-name _version)
+                  (package-name->name+version
+                   (strip-store-file-name (assoc-ref outputs "out"))))
+                (define variant
+                  (string-capitalize
+                   (match:substring (string-match "fira-([a-z]+)" pkg-name) 1)))
+                (match (find-files "." (format #f "^Fira_~a_[0-9]" variant)
+                                   #:directories? #t)
+                  ((dir)
+                   (chdir dir)))))
+            (add-before 'install-license-files 'enter-license-directory
+              (lambda _
+                (chdir ".."))))))
+      ;; While the repository has moved,
+      ;; this specimen still works well as the home-page:
+      (home-page "https://mozilla.github.io/Fira/")
+      (synopsis
+       "Humanist sans-serif with numerous weights emphasizing legibility")
+      (description "Fira Sans is a humanist sans-serif typeface with an emphasis
 on legibility, commissioned by Mozilla from Erik Spiekermann and Ralph du
 Carrois.  The large family includes 2,709 glyphs in normal, condensed, and
 compressed cuts at 11 weights (plus 6 experimental weights), each with