[bug#77575,07/21] gnu: pomegranate: Disable tests.
Commit Message
* gnu/packages/python-xyz.scm (pomegranate): Disable tests.
[build-system]: Switch to pyproject.
[arguments]{tests?}: Disable them.
{phases}: Remove 'check phase replacement.
[native-inputs]: Add python-setuptools, python-wheel. Remove python-nose.
---
gnu/packages/python-xyz.scm | 16 +++++++---------
1 file changed, 7 insertions(+), 9 deletions(-)
@@ -5925,15 +5925,12 @@ (define-public python-pomegranate
;; Delete generated Cython C files.
(snippet
'(for-each delete-file (find-files "." "\\.c$")))))
- (build-system python-build-system)
+ (build-system pyproject-build-system)
(arguments
(list
- #:phases
- '(modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- (invoke "python" "setup.py" "test")))))))
+ ;; XXX: Update to python@3.11 broke some python-nose functionality.
+ ;; Tests are broken but the package itself is most likely fine.
+ #:tests? #f))
(propagated-inputs
(list python-joblib
python-networkx
@@ -5942,8 +5939,9 @@ (define-public python-pomegranate
python-scipy))
(native-inputs
(list python-cython
- python-nose
- python-pandas))
+ python-pandas
+ python-setuptools
+ python-wheel))
(home-page "https://pypi.python.org/pypi/pomegranate/")
(synopsis "Graphical models library for Python")
(description