[bug#77575,04/21] gnu: python-lazr-config: Update to 3.1.
Commit Message
* gnu/packages/python-xyz.scm (python-lazr-config): Update to 3.1.
[build-system]: Switch to pyproject.
[arguments]{test-flags}: Run tests in output.
{phases}: Add a 'check-cleanup phase to remove tests from output.
[native-inputs]: Remove python-nose. Add python-pytest,
python-setuptools, python-wheel.
---
gnu/packages/python-xyz.scm | 30 +++++++++++++++++++-----------
1 file changed, 19 insertions(+), 11 deletions(-)
@@ -34656,23 +34656,31 @@ (define-public python-lazr-delegates
(define-public python-lazr-config
(package
(name "python-lazr-config")
- (version "2.2.3")
+ (version "3.1")
(source
(origin
(method url-fetch)
- (uri (pypi-uri "lazr.config" version))
+ (uri (pypi-uri "lazr_config" version))
(sha256
- (base32
- "1qdbrzl61q7cjhbnxvw9y3frcr935y7diwy15xrwcv9ynvw76jmp"))))
- (build-system python-build-system)
+ (base32 "02xb4fs9rm6bf3f00qkq8pihgqvrvn2wfnvydn2vg9p73ddhcmvw"))))
+ (build-system pyproject-build-system)
(arguments
- '(#:phases
- (modify-phases %standard-phases
- (replace 'check
- (lambda _
- (invoke "python" "-s" "-m" "nose" "-P" "lazr"))))))
+ (list
+ #:test-flags #~(list "-v" #$output)
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'check 'check-cleanup
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (for-each
+ delete-file-recursively
+ (find-files #$output
+ (lambda (file stat)
+ (or (member (basename file)
+ '("tests" ".pytest_cache"))))
+ #:directories? #t))))))))
(native-inputs
- (list python-nose))
+ (list python-pytest python-setuptools python-wheel))
(propagated-inputs
(list python-lazr-delegates python-zope-interface))
(home-page "https://launchpad.net/lazr.config")