[bug#77575,17/21] gnu: python-gixy: Rename package to python-gixy-ng.

Message ID 20250406123732.31301-17-ngraves@ngraves.fr
State New
Headers
Series More patches |

Commit Message

Nicolas Graves April 6, 2025, 12:37 p.m. UTC
  * gnu/packages/check.scm (python-gixy): Deprecate package, defaults to
python-gixy-ng.
(python-gixy-ng): New variable.
---
 gnu/packages/check.scm | 69 ++++++++++++++++++++++--------------------
 1 file changed, 36 insertions(+), 33 deletions(-)
  

Patch

diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index c9b96c14bd..ef5a23de86 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -1027,40 +1027,43 @@  (define-public kyua
 report generation engine.")
     (license license:bsd-3)))
 
-(define-public python-gixy
-  ;; The 0.1.20 release is missing some important fixes.
-  ;; XXX: Commit 'e9008dcbd11f43ccac109b0cf2bf98a94e76b449' breaks tests
-  ;; since it improperly removes an import.
-  (let ((commit "303eb6887ddecab18138b6e427b04ae77c41d2f1")
-        (revision "0")
-        (base-version "0.1.20"))
-    (package
-      (name "python-gixy")
-      (version (git-version base-version revision commit))
-      (source (origin
-                (method git-fetch)
-                (uri (git-reference
-                      (url "https://github.com/yandex/gixy")
-                      (commit commit)))
-                (file-name (git-file-name name version))
-                (sha256
-                 (base32
-                  "0gymjcnvjx9snyrzdbmjnk93ibb161q72xam29vnl3yyac4r1330"))))
-      (build-system pyproject-build-system)
-      (native-inputs (list python-nose python-setuptools python-wheel))
-      (propagated-inputs
-       (list python-cached-property python-configargparse
-             python-jinja2 python-six
-             ;; XXX: gixy is incompatible with pyparsing >= 3.x.
-             ;; See <https://github.com/yandex/gixy/pull/132> and
-             ;; <https://github.com/yandex/gixy/pull/122>.
-             python-pyparsing-2.4.7))
-      (home-page "https://github.com/yandex/gixy")
-      (synopsis "Static NGINX configuration analyzer")
-      (description "Gixy is a static analyzer whose main goal is to help
+(define-public python-gixy-ng
+  (package
+    (name "python-gixy-ng")
+    (version "0.2.7")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/dvershinin/gixy")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0dipvy8y1nlhpka0cdk6hyv1j2388y7isbajpwskjrgqc5vayqx8"))))
+    (build-system pyproject-build-system)
+    ;; This package currently doesn't test properly, but we can't add
+    ;; pytest because it propagates another version of python-pyparsing
+    ;; that takes precedence over the right one.
+    (propagated-inputs (list python-configargparse
+                             python-jinja2
+                             python-pyparsing-2.4.7
+                             python-six))
+    (native-inputs (list python-cached-property
+                         python-setuptools
+                         python-wheel))
+    (home-page "https://github.com/dvershinin/gixy")
+    (synopsis "Static NGINX configuration analyzer")
+    (description "Gixy is a static analyzer whose main goal is to help
 prevent common NGINX misconfigurations.  It provides the @command{gixy}
-command.")
-      (license license:mpl2.0))))
+command.
+
+Note: This is an actively maintained fork of the original @code{python-gixy}
+package.")
+    (license license:mpl2.0)))
+
+(define-deprecated/public python-gixy python-gixy-ng
+  (package/inherit python-gixy-ng
+    (name "python-gixy")))
 
 (define-public googletest
   (package