[bug#77556] gnu: flightgear: Fix build by reordering phases.
Commit Message
Guix can't find the `install-data' phase yet when `check' is redefined, so
swap the definitions of `install-data' and `check'.
* gnu/packages/games.scm (flightgear): Swap `install-data' and `check'.
Change-Id: Ifb4e4f0f3a09a2d2e596681ecb7c6c481f0e16b1
---
gnu/packages/games.scm | 10 +++++-----
1 file changed, 5 insertions(+), 5 deletions(-)
Comments
Timo Wilken <guix@twilken.net> writes:
> Guix can't find the `install-data' phase yet when `check' is redefined, so
> swap the definitions of `install-data' and `check'.
>
> * gnu/packages/games.scm (flightgear): Swap `install-data' and `check'.
Pushed as commit 85eb725, with simplified commit message, thanks.
@@ -10665,10 +10665,6 @@ (define-public flightgear
(lambda* args
((assoc-ref %standard-phases 'build)
#:make-flags (list "fgfs_test_suite"))))
- ;; Test suite needs access to FGData so run it after 'install.
- (delete 'check)
- (add-after 'install-data 'check
- (assoc-ref %standard-phases 'check))
(add-after 'install 'install-data
(lambda _
(let ((share (string-append #$output "/share/flightgear")))
@@ -10676,7 +10672,11 @@ (define-public flightgear
(with-directory-excursion share
(invoke "tar" "xf"
#$(this-package-native-input "flightgear-data")
- "--strip-components=1"))))))))
+ "--strip-components=1")))))
+ ;; Test suite needs access to FGData so run it after 'install.
+ (delete 'check)
+ (add-after 'install-data 'check
+ (assoc-ref %standard-phases 'check)))))
(inputs
(list boost
dbus