[bug#77541,06/38] gnu: python-pytroch-geometric: Skip failing tests.

Message ID 20250404191717.32747-6-ngraves@ngraves.fr
State New
Headers
Series Further patches on python-team. |

Commit Message

Nicolas Graves April 4, 2025, 7:16 p.m. UTC
  * gnu/packages/machine-learning.scm (python-pytroch-geometric):
[arguments]{test-flags}: Skip test_type_repr failing test.
---
 gnu/packages/machine-learning.scm | 5 ++++-
 1 file changed, 4 insertions(+), 1 deletion(-)
  

Patch

diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index e7923bd503..fb1d5d2eed 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -5399,7 +5399,10 @@  (define-public python-pytorch-geometric
                    ;; These refuse to be run on CPU and really want a GPU
                    " and not test_add_random_walk_pe"
                    " and not test_asap"
-                   " and not test_two_hop"))
+                   " and not test_two_hop"
+                   ;; Failed when switched to python@3.11
+                   ;; typing module internals
+                   " and not test_type_repr"))
       #:phases
       '(modify-phases %standard-phases
          (add-after 'unpack 'delete-top-level-directories