[bug#77541,34/38] gnu: Remove python-cookies.

Message ID 20250404191717.32747-34-ngraves@ngraves.fr
State New
Headers
Series [bug#77541,01/38] gnu: Add clipper2. |

Commit Message

Nicolas Graves April 4, 2025, 7:17 p.m. UTC
  This is a leaf package in python, broken and undevelopped for 10 years.

* gnu/packages/python-web.scm (python-cookies): Delete variable.
---
 gnu/packages/python-web.scm | 22 ----------------------
 1 file changed, 22 deletions(-)
  

Patch

diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index e82d59037c..8bb808b846 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -5496,28 +5496,6 @@  (define-public python-flask-multistatic
 for overriding static files.")
     (license license:gpl3+)))
 
-(define-public python-cookies
-  (package
-    (name "python-cookies")
-    (version "2.2.1")
-    (source (origin
-              (method url-fetch)
-              (uri (pypi-uri "cookies" version))
-              (sha256
-               (base32
-                "13pfndz8vbk4p2a44cfbjsypjarkrall71pgc97glk5fiiw9idnn"))))
-    (build-system python-build-system)
-    (arguments
-     `(;; test are broken: https://gitlab.com/sashahart/cookies/issues/3
-       #:tests? #f))
-    (native-inputs
-     (list python-pytest))
-    (synopsis "HTTP cookie parser and renderer")
-    (description "A RFC 6265-compliant HTTP cookie parser and renderer in
-Python.")
-    (home-page "https://gitlab.com/sashahart/cookies")
-    (license license:expat)))
-
 (define-public python-responses
   (package
     (name "python-responses")