[bug#77541,33/38] gnu: python-port-for: Update to 0.7.4.

Message ID 20250404191717.32747-33-ngraves@ngraves.fr
State New
Headers
Series [bug#77541,01/38] gnu: Add clipper2. |

Commit Message

Nicolas Graves April 4, 2025, 7:17 p.m. UTC
  * gnu/packages/python-web.scm (python-port-for): Update to 0.7.4.
[build-system]: Switch to pyproject.
[native-inputs]: Remove python-mock.  Add python-setuptools,
python-wheel.
---
 gnu/packages/python-web.scm | 18 +++++-------------
 1 file changed, 5 insertions(+), 13 deletions(-)
  

Patch

diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 579386e5ab..e82d59037c 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -7701,26 +7701,18 @@  (define-public grip
 (define-public python-port-for
   (package
     (name "python-port-for")
-    (version "0.4")
+    (version "0.7.4")
     (source
      (origin
        (method url-fetch)
-       (uri (pypi-uri "port-for" version))
+       (uri (pypi-uri "port_for" version))
        (sha256
-        (base32
-         "1pncxlj25ggw99r0ijfbkq70gd7cbhqdx5ivsxy4jdp0z14cpda7"))))
-    (build-system python-build-system)
-    (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         (add-after 'unpack 'use-urllib3
-           (lambda _
-             (substitute* "port_for/_download_ranges.py"
-               (("urllib2") "urllib3")))))))
+        (base32 "13826s2d4hzzmv69wws6a7ryhminclv2bqaw6cpl929gnbki6xzw"))))
+    (build-system pyproject-build-system)
     (propagated-inputs
      (list python-urllib3))
     (native-inputs
-     (list python-mock))
+     (list python-pytest python-setuptools python-wheel))
     (home-page "https://github.com/kmike/port-for/")
     (synopsis "TCP localhost port finder and association manager")
     (description