[bug#77541,29/38] gnu: python-rq: Update to 2.3.1.

Message ID 20250404191717.32747-29-ngraves@ngraves.fr
State New
Headers
Series [bug#77541,01/38] gnu: Add clipper2. |

Commit Message

Nicolas Graves April 4, 2025, 7:17 p.m. UTC
  * gnu/packages/databases.scm (python-rq): Update to 2.3.1.
[build-system]: Switch to pyproject.
[arguments]{phases}: Delete 'check phase replacement. Improve style.
[native-inputs]: Add python-hatchling.
---
 gnu/packages/databases.scm | 30 +++++++++++++-----------------
 1 file changed, 13 insertions(+), 17 deletions(-)
  

Patch

diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 097617e094..4ecf237115 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -4611,7 +4611,7 @@  (define-public python-aioredis
 (define-public python-rq
   (package
     (name "python-rq")
-    (version "1.11.1")
+    (version "2.3.1")
     (source
      (origin
        (method git-fetch)
@@ -4620,24 +4620,20 @@  (define-public python-rq
              (commit (string-append "v" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "0dnjm2s036l4j4ypq0h903vh132dp2wiwjrn8jicz1nw829dqpzf"))))
-    (build-system python-build-system)
+        (base32 "1w9aqvbvh1mfpgng0mdcskxl5y3ybcqqai5dnwgvg18am0xxhya6"))))
+    (build-system pyproject-build-system)
     (arguments
-     '(#:phases (modify-phases %standard-phases
-                  (add-before 'check 'start-redis
-                    (lambda _
-                      (invoke "redis-server" "--daemonize" "yes")))
-                  (replace 'check
-                    (lambda* (#:key outputs #:allow-other-keys)
-                      (let ((out (assoc-ref outputs "out")))
-                        ;; Drop test that needs the SDK for Sentry.io.
-                        (delete-file "tests/test_sentry.py")
-                        ;; Ensure 'rq' and 'rqworker' ends up on PATH.
-                        (setenv "PATH" (string-append out "/bin:"
-                                                      (getenv "PATH")))
-                        (invoke "pytest" "-vv")))))))
+     (list
+      #:phases #~(modify-phases %standard-phases
+                   (add-before 'check 'start-redis
+                     (lambda _
+                       (invoke "redis-server" "--daemonize" "yes"))))))
     (native-inputs
-     (list python-mock python-psutil python-pytest redis))
+     (list python-hatchling
+           python-mock
+           python-psutil
+           python-pytest
+           redis))
     (propagated-inputs
      (list python-click python-redis))
     (home-page "https://python-rq.org/")