[bug#77541,28/38] gnu: python-furl: Update to 2.1.4.

Message ID 20250404191717.32747-28-ngraves@ngraves.fr
State New
Headers
Series [bug#77541,01/38] gnu: Add clipper2. |

Commit Message

Nicolas Graves April 4, 2025, 7:17 p.m. UTC
  * gnu/packages/python-web.scm (python-furl): Update to 2.1.4.
[build-system]: Swtich to pyproject.
[arguments]{test-flags}: Ignore failing tests.
[propagated-inputs]: Sort.
[native-inputs]: Add python-pytest, python-setuptools, python-wheel.
---
 gnu/packages/python-web.scm | 16 ++++++++++------
 1 file changed, 10 insertions(+), 6 deletions(-)
  

Patch

diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index bf379c3699..579386e5ab 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -1941,19 +1941,23 @@  (define-public python-falcon-cors
 (define-public python-furl
   (package
     (name "python-furl")
-    (version "2.1.3")
+    (version "2.1.4")
     (source
       (origin
         (method url-fetch)
         (uri (pypi-uri "furl" version))
         (sha256
-          (base32
-            "0knc76pm8pzigs3bpx9fccfsfxqrgblqphar46hq9i364vz8hqas"))))
-    (build-system python-build-system)
+          (base32 "05b058xisv8kghvcpaxvssml2jjkh1cmzyrrjwk2kjb62985fxl7"))))
+    (build-system pyproject-build-system)
+    (arguments
+     (list #:test-flags
+           #~(list "-k" (string-append "not test_hosts"
+                                       " and not test_netloc"
+                                       " and not test_odd_urls"))))
     (propagated-inputs
-     (list python-six python-orderedmultidict))
+     (list python-orderedmultidict python-six))
     (native-inputs
-     (list python-flake8))
+     (list python-flake8 python-pytest python-setuptools python-wheel))
     (home-page "https://github.com/gruns/furl")
     (synopsis "URL manipulation in Python")
     (description "Furl provides an easy-to-use alternative to the