[bug#77541,25/38] gnu: Add python-poetry-core-next.

Message ID 20250404191717.32747-25-ngraves@ngraves.fr
State New
Headers
Series [bug#77541,01/38] gnu: Add clipper2. |

Commit Message

Nicolas Graves April 4, 2025, 7:16 p.m. UTC
  * gnu/packages/python-build.scm (python-poetry-core-next): New variable.
---
 gnu/packages/python-build.scm | 10 ++++++++++
 1 file changed, 10 insertions(+)
  

Patch

diff --git a/gnu/packages/python-build.scm b/gnu/packages/python-build.scm
index 6bea44fee6..9ac325094d 100644
--- a/gnu/packages/python-build.scm
+++ b/gnu/packages/python-build.scm
@@ -571,6 +571,16 @@  (define-public python-poetry-core
 compatible build front-ends to build Poetry managed projects.")
     (license license:expat)))
 
+(define-public python-poetry-core-next
+  (package/inherit python-poetry-core
+    (version "2.1.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "poetry_core" version))
+       (sha256
+        (base32 "015a0802radb2x5wsbywm4fggv4s1srh8zyml5v58xgrxg8bpnzr"))))))
+
 ;;; This package exists to bootstrap python-tomli.
 (define-public python-flit-core-bootstrap
   (package