[bug#77541,21/38] gnu: python-pgmpy: Update to 1.0.0.

Message ID 20250404191717.32747-21-ngraves@ngraves.fr
State New
Headers
Series Further patches on python-team. |

Commit Message

Nicolas Graves April 4, 2025, 7:16 p.m. UTC
  * gnu/packages/statistics.scm (python-pgmpy): Update to 1.0.0.
[arguments]{test-flags}: Ignore failing tests.
[native-inputs]: Add python-pyro-ppl, python-setuptools, python-wheel,
python-xgboost.
---
 gnu/packages/statistics.scm | 16 +++++++++++++---
 1 file changed, 13 insertions(+), 3 deletions(-)
  

Patch

diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 40991caab5..f883786f81 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -8312,7 +8312,7 @@  (define-public ruby-enumerable-statistics
 (define-public python-pgmpy
   (package
     (name "python-pgmpy")
-    (version "0.1.24")
+    (version "1.0.0")
     (source
      (origin
        (method git-fetch)  ;pypi package does not include test data
@@ -8322,8 +8322,14 @@  (define-public python-pgmpy
        (file-name (git-file-name name version))
        (sha256
         (base32
-         "0fvzh6v0yhgdryczamvzhfy2ymywkh0ssx4rl47xnfvi43hnij90"))))
+         "1hg6wrg3jcac71zn4gknni1wrn38wa86ka3sgp2bndz59mx6sr2s"))))
     (build-system pyproject-build-system)
+    (arguments
+     (list #:test-flags
+           #~(list "-k" (string-append
+                         "not test_pillai"
+                         " and not test_estimate_with_cache_no_llm_calls"
+                         " and not test_estimate_with_orientations"))))
     (propagated-inputs (list python-daft
                              python-joblib
                              python-networkx
@@ -8337,7 +8343,11 @@  (define-public python-pgmpy
                              python-statsmodels
                              python-tqdm))
     (native-inputs (list python-mock
-                         python-pytest))
+                         python-pyro-ppl
+                         python-pytest
+                         python-setuptools
+                         python-wheel
+                         python-xgboost))
     (home-page "https://github.com/pgmpy/pgmpy")
     (synopsis "Probabilistic Graphical Models library")
     (description "This package provides a library for Probabilistic