[bug#77541,20/38] gnu: python-botorch: Update to 0.13.0.

Message ID 20250404191717.32747-20-ngraves@ngraves.fr
State New
Headers
Series [bug#77541,01/38] gnu: Add clipper2. |

Commit Message

Nicolas Graves April 4, 2025, 7:16 p.m. UTC
  * gnu/packages/machine-learning.scm (python-botorch): Update to
0.13.0.
[native-inputs]: Add python-pyre-extensions.
---
 gnu/packages/machine-learning.scm | 7 ++++---
 1 file changed, 4 insertions(+), 3 deletions(-)
  

Patch

diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index 4bf7442e09..e62535d890 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -6161,7 +6161,7 @@  (define-public python-gpytorch
 (define-public python-botorch
   (package
     (name "python-botorch")
-    (version "0.11.3")
+    (version "0.13.0")
     (source (origin
               (method git-fetch) ;no tests in PyPI
               (uri (git-reference
@@ -6170,7 +6170,7 @@  (define-public python-botorch
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "0nf9zrg1khvckb8kdpffqc3bnlhc0x03jd1560qmjamwl3j59m02"))))
+                "1sxgxdq892vg5xj30kb86003b9rwsipc95c7p1zdv865y4f38a8y"))))
     (build-system pyproject-build-system)
     (arguments
      (list #:test-flags #~(list "-k" "not test_all_cases_covered")
@@ -6189,7 +6189,8 @@  (define-public python-botorch
                              python-pyro-ppl
                              python-pytorch
                              python-scipy))
-    (native-inputs (list python-pytest
+    (native-inputs (list python-pyre-extensions
+                         python-pytest
                          python-pytest-cov
                          python-setuptools
                          python-setuptools-scm