[bug#77541,19/38] gnu: python-gpytorch: Update to 1.14.

Message ID 20250404191717.32747-19-ngraves@ngraves.fr
State New
Headers
Series [bug#77541,01/38] gnu: Add clipper2. |

Commit Message

Nicolas Graves April 4, 2025, 7:16 p.m. UTC
  * gnu/packages/machine-learning.scm (python-gpytorch): Update to 1.14.
[arguments]{test-flags}: Ignore additional failing test.
[propagated-inputs]: Add python-jaxtyping.
[native-inputs]: Add python-setuptools, python-wheel.
---
 gnu/packages/machine-learning.scm | 19 +++++++++++++------
 1 file changed, 13 insertions(+), 6 deletions(-)
  

Patch

diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index e5dd247c7d..4bf7442e09 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -6124,27 +6124,34 @@  (define-public python-linear-operator
 (define-public python-gpytorch
   (package
     (name "python-gpytorch")
-    (version "1.12")
+    (version "1.14")
     (source (origin
               (method url-fetch)
               (uri (pypi-uri "gpytorch" version))
               (sha256
                (base32
-                "1pwsccll1hrgkifdmlxzcn6cvnwvyq2cimqzbfgihr13yw51cb6w"))))
+                "13cs6dx8qa5j4ygji9w5xbmaqc68ihqyzz33fyyf9qa6d8gc2b03"))))
     (build-system pyproject-build-system)
     (arguments
      (list #:test-flags
-           ;; test_deprecated_methods fails with an AssertionError.
-           #~(list "-k" (string-append "not test_deprecated_methods")
+           #~(list "-k" (string-append
+                         ;; test_deprecated_methods fails with an AssertionError.
+                         "not test_deprecated_methods"
+                         ;; This test is flaky: Expects gradients of 0 exactly,
+                         ;; can get negligible ones (e-10 to e-16).
+                         " and not test_optimization_optimal_error")
                    ;; Ignore lenghty tests of little relevance.
                    "--ignore=test/examples/")))
-    (propagated-inputs (list python-linear-operator
+    (propagated-inputs (list python-jaxtyping
+                             python-linear-operator
                              python-mpmath
                              python-scikit-learn
                              python-scipy))
     (native-inputs (list python-nbval
                          python-pytest
-                         python-setuptools))
+                         python-setuptools
+                         python-setuptools-scm
+                         python-wheel))
     (home-page "https://gpytorch.ai")
     (synopsis "Implementation of Gaussian Processes in PyTorch")
     (description