[bug#77541,17/38] gnu: gpytorch: Remove uneeded inputs.

Message ID 20250404191717.32747-17-ngraves@ngraves.fr
State New
Headers
Series [bug#77541,01/38] gnu: Add clipper2. |

Commit Message

Nicolas Graves April 4, 2025, 7:16 p.m. UTC
  * gnu/packages/machine-learning.scm (gpytorch): Remove uneeded inputs.
[arguments]{test-flags}: Ignore costly examples tests.
[native-inputs]: Remove python-coverage, python-flake8,
python-flake8-print, python-twine.
---
 gnu/packages/machine-learning.scm | 12 +++++-------
 1 file changed, 5 insertions(+), 7 deletions(-)
  

Patch

diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index 615768c492..dcebf89376 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -6135,18 +6135,16 @@  (define-public python-gpytorch
     (arguments
      (list #:test-flags
            ;; test_deprecated_methods fails with an AssertionError.
-           #~(list "-k" (string-append "not test_deprecated_methods"))))
+           #~(list "-k" (string-append "not test_deprecated_methods")
+                   ;; Ignore lenghty tests of little relevance.
+                   "--ignore=test/examples/")))
     (propagated-inputs (list python-linear-operator
                              python-mpmath
                              python-scikit-learn
                              python-scipy))
-    (native-inputs (list python-coverage
-                         python-flake8
-                         python-flake8-print
-                         python-nbval
+    (native-inputs (list python-nbval
                          python-pytest
-                         python-setuptools
-                         python-twine))
+                         python-setuptools))
     (home-page "https://gpytorch.ai")
     (synopsis "Implementation of Gaussian Processes in PyTorch")
     (description