[bug#77541,16/38] gnu: python-linear-operator: Update to 0.6.

Message ID 20250404191717.32747-16-ngraves@ngraves.fr
State New
Headers
Series Further patches on python-team. |

Commit Message

Nicolas Graves April 4, 2025, 7:16 p.m. UTC
  * gnu/packages/machine-learning.scm (python-linear-operator): Update
to 0.6.
[propagated-inputs]: Remove python-typeguard. Add python-mpmath.
[native-inputs]: Remove python-flake8, python-flake8-print,
python-twine. Add python-typeguard, python-wheel.
---
 gnu/packages/machine-learning.scm | 15 +++++++--------
 1 file changed, 7 insertions(+), 8 deletions(-)
  

Patch

diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index fb1d5d2eed..615768c492 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -6098,24 +6098,23 @@  (define-public python-pyro-ppl
 (define-public python-linear-operator
   (package
     (name "python-linear-operator")
-    (version "0.5.2")
+    (version "0.6")
     (source (origin
               (method url-fetch)
               (uri (pypi-uri "linear_operator" version))
               (sha256
                (base32
-                "03drb4hn9nn8jrqd9vbalihhahgpdm956hbs05bix7svradhknaw"))))
+                "0m56f3zrm8xh1bpwh4g7jfc79rf4j94g6zmz663b58pig4w6dqm9"))))
     (build-system pyproject-build-system)
     (propagated-inputs (list python-jaxtyping
+                             python-mpmath
                              python-pytorch
-                             python-scipy
-                             python-typeguard))
-    (native-inputs (list python-flake8
-                         python-flake8-print
-                         python-pytest
+                             python-scipy))
+    (native-inputs (list python-pytest
                          python-setuptools
                          python-setuptools-scm
-                         python-twine))
+                         python-typeguard
+                         python-wheel))
     (home-page "https://github.com/cornellius-gp/linear_operator/")
     (synopsis "Linear operator implementation")
     (description "LinearOperator is a PyTorch package for abstracting away the