[bug#77541,14/38] gnu: python-pyro4: Update to 4.82.
Commit Message
* gnu/packages/python-xyz.scm (python-pyro4): Update to 4.82.
[build-system]: Switch to pyproject-build-system.
[arguments]{tests?}: Remove to enable tests.
{test-flags}: Skip missing tests.
{phases}: Add 'check phase replacement.
[native-inputs]: Add python-setuptools, python-wheel.
---
gnu/packages/python-xyz.scm | 45 ++++++++++++++++++++++++++++++++-----
1 file changed, 40 insertions(+), 5 deletions(-)
@@ -28438,18 +28438,53 @@ (define-public python-semver
(define-public python-pyro4
(package
(name "python-pyro4")
- (version "4.77")
+ (version "4.82")
(source
(origin
(method url-fetch)
(uri (pypi-uri "Pyro4" version))
(sha256
- (base32 "0gsjg869y4gpy265s1gj1f2qy6jn5iz8r2bwwnq78r1r5yi15zib"))))
- (build-system python-build-system)
+ (base32 "1yr1rv2afmq55wb14sx9qplzkqw7fya9rprsqdyxfbg90h45n7si"))))
+ (build-system pyproject-build-system)
(arguments
- '(#:tests? #f)) ;FIXME: Some tests require network access.
+ (list #:test-flags
+ #~(list "-k"
+ (string-join
+ ;; Those tests require network.
+ (list "testBCstart"
+ "testAutoClean"
+ "testDaemonPyroObj"
+ "testLookupAndRegister"
+ "testLookupInvalidHmac"
+ "testLookupUnixsockParsing"
+ "testMulti"
+ "testRefuseDottedNames"
+ "testResolve"
+ "testBCLookup0000"
+ "testPyroname"
+ "testResolveAsymmetricHmacUsage"
+ "testResolveWrongHmac"
+ "testStartNSfunc"
+ "testCustomDictClass"
+ "testDictClassFail"
+ "testBroadcast"
+ "testGetIP"
+ ;; XXX: Unclear why this test fails.
+ "testCustomClassFail")
+ " and not "))
+ #:phases
+ #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? test-flags #:allow-other-keys)
+ (if tests?
+ (apply invoke "python" "-m" "unittest" test-flags)
+ (format #t "test suite not run.~%")))))))
(native-inputs
- (list python-cloudpickle python-dill python-msgpack))
+ (list python-cloudpickle
+ python-dill
+ python-msgpack
+ python-setuptools
+ python-wheel))
(propagated-inputs
(list python-serpent))
(home-page "https://pyro4.readthedocs.io")