[bug#77541,12/38] gnu: python-attr: Update to 0.3.2.

Message ID 20250404191717.32747-12-ngraves@ngraves.fr
State New
Headers
Series Further patches on python-team. |

Commit Message

Nicolas Graves April 4, 2025, 7:16 p.m. UTC
  * gnu/packages/python-xyz.scm (python-attr): Update to 0.3.2.
---
 gnu/packages/python-xyz.scm | 9 +++++----
 1 file changed, 5 insertions(+), 4 deletions(-)
  

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 01dfc0799f..8100b030c5 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -31373,15 +31373,16 @@  (define-public python-doctest-ignore-unicode
 (define-public python-attr
   (package
     (name "python-attr")
-    (version "0.3.1")
+    (version "0.3.2")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "attr" version))
        (sha256
-        (base32
-         "0pbpskvxp5hzdvcaf766ljwpckshir8sf7z6jqji6zyib20594ch"))))
-    (build-system python-build-system)
+        (base32 "1x2627x0n2rxx8wib4cksbjjnncff8finq97k37dq70qd2kvrvhw"))))
+    (build-system pyproject-build-system)
+    (native-inputs
+     (list python-setuptools python-wheel))
     (home-page "https://github.com/denis-ryzhkov/attr")
     (synopsis "Decorator for attributes of target function or class")
     (description "Simple decorator to set attributes of target function or