[bug#77537,2/2] gnu: netcdf-cxx4: Move netcdf to the propagated-inputs.

Message ID 20250404163926.109643-2-luca.cirrottola@inria.fr
State New
Headers
Series gnu: netcdf-cxx4: Move netcdf to the propagated-inputs |

Commit Message

Luca Cirrottola April 4, 2025, 4:39 p.m. UTC
  ---
 gnu/packages/maths.scm | 6 ++++--
 1 file changed, 4 insertions(+), 2 deletions(-)
  

Patch

diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 0e50e7a460..ad49899d74 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -2432,7 +2432,8 @@  (define-public netcdf-cxx4
                                               (search-input-file
                                                %build-inputs
                                                "/lib/libhdf5.so")))))
-    (inputs (list netcdf hdf5))
+    (inputs (list hdf5))
+    (propagated-inputs (list netcdf))
     (home-page "https://github.com/Unidata/netcdf-cxx4")
     (synopsis "NetCDF C++ interface")
     (description
@@ -2447,7 +2448,8 @@  (define-public netcdf-cxx4-parallel-openmpi
     (synopsis "NetCDF C++ interface (with MPI support)")
     (inputs (modify-inputs (package-inputs netcdf-cxx4)
               (prepend openmpi)
-              (replace "hdf5" hdf5-parallel-openmpi)
+              (replace "hdf5" hdf5-parallel-openmpi)))
+    (propagated-inputs (modify-inputs (package-propagated-inputs netcdf-cxx4)
               (replace "netcdf" netcdf-parallel-openmpi)))))
 
 (define-public n2p2