[bug#77521] gnu: Add jupp.

Message ID 20250404015346.3246920-1-nomike@nomike.com
State New
Headers
Series [bug#77521] gnu: Add jupp. |

Commit Message

nomike April 4, 2025, 1:52 a.m. UTC
  * gnu/packages/text-editors.scm (jupp): New variable.

Change-Id: I8e030ec4b9e78dc7bb5a020f69aeb6e2c3886b60
---
 gnu/packages/text-editors.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)
  

Patch

diff --git a/gnu/packages/text-editors.scm b/gnu/packages/text-editors.scm
index 9a72c74cac..f1c656ff26 100644
--- a/gnu/packages/text-editors.scm
+++ b/gnu/packages/text-editors.scm
@@ -718,6 +718,33 @@  (define-public joe
 bindings and many of the powerful features of GNU Emacs.")
     (license license:gpl3+)))
 
+(define-public jupp
+  (package
+    (name "jupp")
+    (version "3.1jupp41")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "http://www.mirbsd.org/MirOS/dist/jupp/joe-" version
+                           ".tgz"))
+       (sha256
+        (base32
+         "0by8c640kxdf05xvrj8n6awg5mq847iwkhryz7zzxghryn5fmf3v"))))
+    (build-system gnu-build-system)
+    (inputs (list ncurses))
+    (home-page "http://mirbsd.de/jupp")
+    (synopsis "User friendly full screen text editor")
+    (description
+    "This is the portable version of JOE’s Own Editor, which is currently developed at sourceforge,
+licenced under the GNU General Public License, Version 1, using autoconf/automake. This version has
+been enhanced by several functions intended for programmers or other professional users, and has a
+lot of bugs fixed. It is based upon an older version of joe because these behave better overall.
+jupp also does come with the editor flavours known from joe, specifically, jmacs, joe, jpico,
+jstar, and rjoe. Not all features of jupp are available for these though (but all the bugfixes, and
+syntax highlighting is still enabled by default for these, while it is not auto-enabled in jupp).")
+    (license license:gpl1+)))
++
+
 (define-public jucipp
   (package
     (name "jucipp")