[bug#77506] gnu: xdisorg: Add hyprsunset.
Commit Message
This adds the hyprsunset utility for Hyprland.
---
gnu/packages/xdisorg.scm | 36 ++++++++++++++++++++++++++++++++++++
1 file changed, 36 insertions(+)
@@ -1807,6 +1807,42 @@ (define-public redshift-wayland
protocol.")
(license license:gpl3+))))
+(define-public hyprsunset
+ (package
+ (name "hyprsunset")
+ (version "0.2.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/hyprwm/hyprsunset")
+ (commit (string-append "v" version))))
+ (sha256
+ (base32
+ "049w9b7rbm5nzb51vqwirvm4xy27kqhn4qrhj1k4nj1dfmmn90hh"))))
+ (build-system cmake-build-system)
+ (arguments
+ (list
+ #:cmake cmake-3.30
+ #:tests? #false))
+ (native-inputs
+ (list
+ gcc-14
+ hyprwayland-scanner
+ pkg-config
+ wayland
+ wayland-protocols))
+ (inputs
+ (list
+ hyprland-protocols
+ hyprutils))
+ (home-page "https://github.com/hyprwm/hyprsunset")
+ (synopsis "A blue-light filter for Hyprland")
+ (description "An application to enable a blue-light filter on Hyprland. It does not have
+a timer on its own, but has to be controlled using Hyprland's @code{hyprctl}.")
+ (license license:bsd-3)))
+
(define-public xwhite
(package
(name "xwhite")