[bug#77505] gnu: qt: Add hyprland-qt-support.
Commit Message
Adds hyprland-qt-support. I hope this is a fitting module. Maybe we should think about adding a hyprland-xyz module at some point?
---
gnu/packages/qt.scm | 42 ++++++++++++++++++++++++++++++++++++++++++
1 file changed, 42 insertions(+)
Comments
Em 3 de abril de 2025 17:41:13 BRT, Daniel Ziltener via Guix-patches via <guix-patches@gnu.org> escreveu:
>Adds hyprland-qt-support. I hope this is a fitting module. Maybe we should think about adding a hyprland-xyz module at some point?
>
>---
> gnu/packages/qt.scm | 42 ++++++++++++++++++++++++++++++++++++++++++
> 1 file changed, 42 insertions(+)
>
>diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
>index 94cc879f4a..17dad66af5 100644
>--- a/gnu/packages/qt.scm
>+++ b/gnu/packages/qt.scm
>@@ -442,6 +442,48 @@ (define-public materialdecoration
> (home-page "https://github.com/lirios/materialdecoration")
> (license license:lgpl3+))))
>
>+(define-public hyprland-qt-support
>+ (package
>+ (name "hyprland-qt-support")
>+ (version "0.1.0")
>+ (source
>+ (origin
>+ (method git-fetch)
>+ (uri
>+ (git-reference
>+ (url "https://github.com/hyprwm/hyprland-qt-support")
>+ (commit (string-append "v" version))))
>+ (sha256
>+ (base32
>+ "0rxdj8l985bvsg3gca79jb4rf0dy066x5cmxsyyavlcp7yz6irps"))))
>+ (build-system qt-build-system)
>+ (arguments
>+ (list
>+ #:tests? #false
>+ #:qtbase qtbase
>+ #:configure-flags
>+ #~(list
>+ "-DUSE_QT6=ON"
>+ "-DCMAKE_BUILD_TYPE:STRING=Release"
>+ "-DINSTALL_QML_PREFIX=/lib/qt6/qml")))
>+ (native-inputs
>+ (list
>+ gcc-14
>+ pkg-config
>+ vulkan-headers))
>+ (inputs
>+ (list
>+ qtbase
>+ qtdeclarative
>+ qtsvg
>+ qtwayland
>+ hyprlang))
>+ (home-page "https://github.com/hyprwm/hyprland-qt-support")
>+ (synopsis "A qml style provider for hypr* qt apps")
>+ (description "A qml style provider for hypr* qt apps. \
>+Launch a qt/qmp app with @code{QT_QUICK_CONTROLS_STYLE=org.hyprland.style}.")
>+ (license license:bsd-3)))
>+
> (define-public grantlee
> (package
> (name "grantlee")
Greetings,
If #76910[1] is merged, a hyprland-xyz wouls definetly be
appropriate.
[1] <https://issues.guix.gnu.org/76910>
Regards,
@@ -442,6 +442,48 @@ (define-public materialdecoration
(home-page "https://github.com/lirios/materialdecoration")
(license license:lgpl3+))))
+(define-public hyprland-qt-support
+ (package
+ (name "hyprland-qt-support")
+ (version "0.1.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/hyprwm/hyprland-qt-support")
+ (commit (string-append "v" version))))
+ (sha256
+ (base32
+ "0rxdj8l985bvsg3gca79jb4rf0dy066x5cmxsyyavlcp7yz6irps"))))
+ (build-system qt-build-system)
+ (arguments
+ (list
+ #:tests? #false
+ #:qtbase qtbase
+ #:configure-flags
+ #~(list
+ "-DUSE_QT6=ON"
+ "-DCMAKE_BUILD_TYPE:STRING=Release"
+ "-DINSTALL_QML_PREFIX=/lib/qt6/qml")))
+ (native-inputs
+ (list
+ gcc-14
+ pkg-config
+ vulkan-headers))
+ (inputs
+ (list
+ qtbase
+ qtdeclarative
+ qtsvg
+ qtwayland
+ hyprlang))
+ (home-page "https://github.com/hyprwm/hyprland-qt-support")
+ (synopsis "A qml style provider for hypr* qt apps")
+ (description "A qml style provider for hypr* qt apps. \
+Launch a qt/qmp app with @code{QT_QUICK_CONTROLS_STYLE=org.hyprland.style}.")
+ (license license:bsd-3)))
+
(define-public grantlee
(package
(name "grantlee")