[bug#76718] gnu: wm: Update swayfx to 0.5 and scenefx to 0.2.1.
Commit Message
These packages need to be updated in step, so bundle this into one commit.
* gnu/packages/wm.scm (swayfx): Update to 0.5, requiring scenefx@0.2.1 and
wlroots@0.18. (scenefx): Update to 0.2.1, ditto wlroots.
Change-Id: I2f97f76cd4e2ba7d1cf42fbaed796919a264b790
---
gnu/packages/wm.scm | 12 ++++++------
1 file changed, 6 insertions(+), 6 deletions(-)
@@ -2208,7 +2208,7 @@ (define-public swayfx
(package
(inherit sway)
(name "swayfx")
- (version "0.4")
+ (version "0.5")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -2217,7 +2217,7 @@ (define-public swayfx
(file-name (git-file-name name version))
(sha256
(base32
- "0651gbkszc8wwkiiw983m3815cfyk4c9v4mpd1nqf27a0f6qjgsm"))))
+ "0pvha915hihip59g6dkhjifm9rvwrvgxd3shc6xz99r377prpml1"))))
(build-system meson-build-system)
(inputs (list basu
cairo
@@ -2231,7 +2231,7 @@ (define-public swayfx
scenefx
swaybg
wayland
- wlroots-0.17))
+ wlroots))
(home-page "https://github.com/WillPower3309/swayfx")
(synopsis "Sway Fork with extra options and effects")
(description
@@ -4294,7 +4294,7 @@ (define-public wf-config
(define-public scenefx
(package
(name "scenefx")
- (version "0.1")
+ (version "0.2.1")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -4303,7 +4303,7 @@ (define-public scenefx
(file-name (git-file-name name version))
(sha256
(base32
- "1r7f8bprsn0mwlkmc8d14nr3iibljfyxypb4i06v66ghlngaw6dw"))))
+ "1jvbskpmhq0vs4rx9723n709h77zg4c0cid8jwnrag1hqh601ch4"))))
(build-system meson-build-system)
(native-inputs (list pkg-config
;; for wayland-scanner.
@@ -4312,7 +4312,7 @@ (define-public scenefx
mesa
libxkbcommon
libdrm
- wlroots-0.17))
+ wlroots))
(home-page "https://github.com/wlrfx/scenefx")
(synopsis "Drop-in replacement for the wlroots scene API")
(description