[bug#77467,1/1] gnu: netcdf: Fix propagated inputs.

Message ID 20250402171305.608828-1-luca.cirrottola@inria.fr
State New
Headers
Series netcdf: Fix propagated inputs |

Commit Message

Luca Cirrottola April 2, 2025, 5:13 p.m. UTC
  ---
 gnu/packages/maths.scm | 9 +++++----
 1 file changed, 5 insertions(+), 4 deletions(-)
  

Comments

Luca Cirrottola April 2, 2025, 5:18 p.m. UTC | #1
CC the science team.
  

Patch

diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 6910b32dae..279a5eb39d 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -2286,13 +2286,14 @@  (define-public netcdf
     (native-inputs
      (list m4 doxygen graphviz))
     (inputs
-     (list curl
-           hdf4-alt
-           hdf5
+     (list hdf5
            libjpeg-turbo
-           libxml2
            unzip
            zlib))
+    (propagated-inputs
+     (list curl
+           hdf4-alt
+           libxml2))
     (arguments
      (list #:configure-flags
            #~'("--enable-doxygen" "--enable-dot"