[bug#77458] gnu: lyrebird: Update to 0.6.0.

Message ID 20250402141204.10596-1-nandre@riseup.net
State New
Headers
Series [bug#77458] gnu: lyrebird: Update to 0.6.0. |

Commit Message

André Batista April 2, 2025, 2:12 p.m. UTC
  * gnu/packages/goland.scm (lyrebird): Update to 0.6.0.
[arguments]<#:go>: Set to go-1.22.

Change-Id: I8d54b9e80560f2f6e7bbd071498dede588660a09
---
 gnu/packages/golang.scm | 12 ++++++------
 1 file changed, 6 insertions(+), 6 deletions(-)


base-commit: 5735c278e16517d9be5e26235fe68dea9bae3527
  

Comments

Sharlatan Hellseher April 2, 2025, 7:36 p.m. UTC | #1
Hi André,

May you create the patch from the current go-team branch, it has all
Golang module moved from (gnu packages golang) into corresponded
submodules.

Please, keep the list stile here:
--8<---------------cut here---------------start------------->8---
   (arguments
-     (list
-      #:install-source? #f
-      #:unpack-path "gitlab.torproject.org/tpo/anti-censorship/pluggable-transports/lyrebird"
-      #:import-path "gitlab.torproject.org/tpo/anti-censorship/pluggable-transports/lyrebird/cmd/lyrebird"))
+     `(#:go ,go-1.22
--8<---------------cut here---------------end--------------->8---

e.g.
--8<---------------cut here---------------start------------->8---
   (arguments
     (list
+     #:go go-1.22
      #:install-source? #f
--8<---------------cut here---------------end--------------->8---

Thanks,
Oleg
  

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 791e2db9f9..799dedceef 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -1626,7 +1626,7 @@  (define-public go-github-com-wraparound-wrap
 (define-public lyrebird
   (package
     (name "lyrebird")
-    (version "0.5.0")
+    (version "0.6.0")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -1635,13 +1635,13 @@  (define-public lyrebird
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "1qk7npkj0a3a28rp38whl1jwjr0z0hdcsq5bgm8bl1fk9g6cqbnp"))))
+                "1hhilnk72s0h3cm7zw89n3kiqwa32c0r1a1y5ygp432hmrxvr2b0"))))
     (build-system go-build-system)
     (arguments
-     (list
-      #:install-source? #f
-      #:unpack-path "gitlab.torproject.org/tpo/anti-censorship/pluggable-transports/lyrebird"
-      #:import-path "gitlab.torproject.org/tpo/anti-censorship/pluggable-transports/lyrebird/cmd/lyrebird"))
+     `(#:go ,go-1.22
+       #:install-source? #f
+       #:unpack-path "gitlab.torproject.org/tpo/anti-censorship/pluggable-transports/lyrebird"
+       #:import-path "gitlab.torproject.org/tpo/anti-censorship/pluggable-transports/lyrebird/cmd/lyrebird"))
     (propagated-inputs
      (list go-filippo-io-edwards25519
            go-github-com-dchest-siphash