[bug#77455,4/4] gnu: papirus-icon-theme: Avoid creating executable icons.

Message ID 20250402111623.22287-4-guix@twilken.net
State New
Headers
Series [bug#77455,1/4] gnu: papirus-icon-theme: Update to 20250201. |

Commit Message

Timo Wilken April 2, 2025, 11:16 a.m. UTC
  * gnu/packages/gnome-xyz.scm (papirus-icon-theme) [arguments]:
  Add 'remove-executable-bit phase.

Change-Id: Ic4d4f41b348d728913a90b0ef9cdf50f9901070a
---
 gnu/packages/gnome-xyz.scm | 8 +++++++-
 1 file changed, 7 insertions(+), 1 deletion(-)
  

Comments

Liliana Marie Prikler April 2, 2025, 8:06 p.m. UTC | #1
Am Mittwoch, dem 02.04.2025 um 13:16 +0200 schrieb Timo Wilken:
> * gnu/packages/gnome-xyz.scm (papirus-icon-theme) [arguments]:
>   Add 'remove-executable-bit phase.
> 
> Change-Id: Ic4d4f41b348d728913a90b0ef9cdf50f9901070a
> ---
Pushed with slight style changes and minor rewordings.

Cheers
  

Patch

diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index 2054cd9762..432833a649 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -237,7 +237,13 @@  (define-public papirus-icon-theme
                                 (when (eq? 'regular (stat:type (stat target)))
                                   (delete-file file)
                                   (link target file))))
-                            (find-files "." symlink?))))))))
+                            (find-files "." symlink?)))))
+           (add-before 'install 'remove-executable-bit
+             (lambda _
+               (let ((file? (lambda (_ stat)
+                              (eq? 'regular (stat:type stat)))))
+                 (for-each (lambda (file) (chmod file #o644))
+                           (find-files "." file?))))))))
     (native-inputs
      (list `(,gtk+ "bin")))
     (home-page "https://git.io/papirus-icon-theme")