[bug#77455,4/4] gnu: papirus-icon-theme: Avoid creating executable icons.
Commit Message
* gnu/packages/gnome-xyz.scm (papirus-icon-theme) [arguments]:
Add 'remove-executable-bit phase.
Change-Id: Ic4d4f41b348d728913a90b0ef9cdf50f9901070a
---
gnu/packages/gnome-xyz.scm | 8 +++++++-
1 file changed, 7 insertions(+), 1 deletion(-)
Comments
Am Mittwoch, dem 02.04.2025 um 13:16 +0200 schrieb Timo Wilken:
> * gnu/packages/gnome-xyz.scm (papirus-icon-theme) [arguments]:
> Add 'remove-executable-bit phase.
>
> Change-Id: Ic4d4f41b348d728913a90b0ef9cdf50f9901070a
> ---
Pushed with slight style changes and minor rewordings.
Cheers
@@ -237,7 +237,13 @@ (define-public papirus-icon-theme
(when (eq? 'regular (stat:type (stat target)))
(delete-file file)
(link target file))))
- (find-files "." symlink?))))))))
+ (find-files "." symlink?)))))
+ (add-before 'install 'remove-executable-bit
+ (lambda _
+ (let ((file? (lambda (_ stat)
+ (eq? 'regular (stat:type stat)))))
+ (for-each (lambda (file) (chmod file #o644))
+ (find-files "." file?))))))))
(native-inputs
(list `(,gtk+ "bin")))
(home-page "https://git.io/papirus-icon-theme")