[bug#77455,2/4] gnu: papirus-icon-theme: Use g-exps for arguments.

Message ID 20250402111623.22287-2-guix@twilken.net
State New
Headers
Series [bug#77455,1/4] gnu: papirus-icon-theme: Update to 20250201. |

Commit Message

Timo Wilken April 2, 2025, 11:16 a.m. UTC
  * gnu/packages/gnome-xyz.scm (papirus-icon-theme) [arguments]:
  Use g-expressions instead of plain quoted lists.

Change-Id: I8578fd392d10be3f249c304ffd7e9dbc23952fa1
---
 gnu/packages/gnome-xyz.scm | 40 +++++++++++++++++++-------------------
 1 file changed, 20 insertions(+), 20 deletions(-)
  

Patch

diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index 92867d1177..2a9b50d9b4 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -216,27 +216,27 @@  (define-public papirus-icon-theme
        (file-name (git-file-name name version))))
     (build-system gnu-build-system)
     (arguments
-     '(#:tests? #f                      ; no test suite
-       #:make-flags (list (string-append "PREFIX=" (assoc-ref %outputs "out")))
+     `(#:tests? #f                      ; no test suite
+       #:make-flags ,#~(list (string-append "PREFIX=" (assoc-ref %outputs "out")))
        #:phases
-       (modify-phases %standard-phases
-         (delete 'bootstrap)
-         (delete 'configure)
-         (delete 'build)
-         (add-before 'install 'halve-inode-consumption
-           ;; This package uses over 100K inodes, which is a lot.  We can easily
-           ;; halve that number by using (hard) links, to no ill effect.
-           ;; See <https://logs.guix.gnu.org/guix/2023-01-31.log#171227>.
-           ;; However, the source checkout will still use the full amount!
-           (lambda _
-             (let ((symlink? (lambda (_ stat)
-                               (eq? 'symlink (stat:type stat)))))
-               (for-each (lambda (file)
-                           (let ((target (canonicalize-path file)))
-                             (when (eq? 'regular (stat:type (stat target)))
-                               (delete-file file)
-                               (link target file))))
-                         (find-files "." symlink?))))))))
+       ,#~(modify-phases %standard-phases
+            (delete 'bootstrap)
+            (delete 'configure)
+            (delete 'build)
+            (add-before 'install 'halve-inode-consumption
+              ;; This package uses over 100K inodes, which is a lot.  We can easily
+              ;; halve that number by using (hard) links, to no ill effect.
+              ;; See <https://logs.guix.gnu.org/guix/2023-01-31.log#171227>.
+              ;; However, the source checkout will still use the full amount!
+              (lambda _
+                (let ((symlink? (lambda (_ stat)
+                                  (eq? 'symlink (stat:type stat)))))
+                  (for-each (lambda (file)
+                              (let ((target (canonicalize-path file)))
+                                (when (eq? 'regular (stat:type (stat target)))
+                                  (delete-file file)
+                                  (link target file))))
+                            (find-files "." symlink?))))))))
     (native-inputs
      (list `(,gtk+ "bin")))
     (home-page "https://git.io/papirus-icon-theme")