[bug#77400,26/26] gnu: python-mechanize: Update to 0.4.10.

Message ID 20250331061901.22670-26-ngraves@ngraves.fr
State New
Headers
Series Some further updates |

Commit Message

Nicolas Graves March 31, 2025, 6:18 a.m. UTC
  * gnu/packages/python-xyz.scm (python-mechanize): Update to 0.4.10.
[build-system]: Switch to pyproject-build-system.
[arguments]{tests?}: Disable them.
{phases}: Add 'configure-tests phase to setup GUIX_PYTHONPATH.
[native-inputs]: Add python-html5-parser, python-html5lib,
python-lxml, python-service-identity, python-setuptools, python-six,
python-twisted, python-wheel.
---
 gnu/packages/python-xyz.scm | 26 ++++++++++++++++++++++----
 1 file changed, 22 insertions(+), 4 deletions(-)
  

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 015872902a..3d2bade3fc 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -5167,15 +5167,33 @@  (define-public python-scour
 (define-public python-mechanize
   (package
     (name "python-mechanize")
-    (version "0.4.7")
+    (version "0.4.10")
     (source
      (origin
       (method url-fetch)
       (uri (pypi-uri "mechanize" version))
       (sha256
-       (base32
-        "02b845y85ka5sl2cj93lll3v326d8bww07bq1q0y1643h7sshwqp"))))
-    (build-system python-build-system)
+       (base32 "1pvxjnhqi6iq7nnjksnfvyzxcibbwfjc9fzp22v0msp7kdzr9shx"))))
+    (build-system pyproject-build-system)
+    (arguments
+     ;; XXX: Unclear why tests are failing.
+     (list #:tests? #f
+           #:phases
+           #~(modify-phases %standard-phases
+               (add-before 'check 'configure-tests
+                 (lambda _
+                   (setenv "GUIX_PYTHONPATH"
+                           (string-append (getcwd) "/test-tools:"
+                                          (getenv "GUIX_PYTHONPATH"))))))))
+    (native-inputs
+     (list python-html5-parser
+           python-html5lib
+           python-lxml
+           python-service-identity
+           python-setuptools
+           python-six
+           python-twisted
+           python-wheel))
     (propagated-inputs
      (list python-html5lib))
     (home-page "https://github.com/python-mechanize/mechanize")