[bug#77400,02/26] gnu: python-cchardet: Update to 2.2.0a2.

Message ID 20250331061901.22670-2-ngraves@ngraves.fr
State New
Headers
Series Some further updates |

Commit Message

Nicolas Graves March 31, 2025, 6:18 a.m. UTC
  * gnu/packages/freedesktop.scm (python-cchardet): Update to 2.2.0a2.
---
 gnu/packages/freedesktop.scm | 10 +++++++---
 1 file changed, 7 insertions(+), 3 deletions(-)
  

Patch

diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 34dfe20229..0618fdc6f4 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -68,6 +68,7 @@  (define-module (gnu packages freedesktop)
   #:use-module (guix build-system gnu)
   #:use-module (guix build-system meson)
   #:use-module (guix build-system perl)
+  #:use-module (guix build-system pyproject)
   #:use-module (guix build-system python)
   #:use-module (guix build-system glib-or-gtk)
   #:use-module (guix build-system qt)
@@ -128,6 +129,7 @@  (define-module (gnu packages freedesktop)
   #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages polkit)
   #:use-module (gnu packages python)
+  #:use-module (gnu packages python-build)
   #:use-module (gnu packages python-crypto)
   #:use-module (gnu packages python-xyz)
   #:use-module (gnu packages qt)
@@ -2842,17 +2844,19 @@  (define-public uchardet
 (define-public python-cchardet
   (package
   (name "python-cchardet")
-  (version "2.1.7")
+  (version "2.2.0a2")
   (source
     (origin
       (method url-fetch)
       (uri (pypi-uri "cchardet" version))
       (sha256
         (base32
-          "1bqfz85cd51sw0bvhvdq9ikccxi2ld7g5jpni4jkq1a5clrvca64"))))
-  (build-system python-build-system)
+          "08wq5yfaafbjipabfc6kpyvivkk2394w7isv0mwx5agcf8cbnwnx"))))
+  (build-system pyproject-build-system)
   (inputs
    (list uchardet))
+  (native-inputs
+   (list python-setuptools python-wheel))
   (home-page "https://github.com/PyYoshi/cChardet")
   (synopsis "High-performance character encoding detection for Python")
   (description "cChardet is a character encoding detector, written in