[bug#77400,18/26] gnu: umi-tools: Update to 1.1.6.
Commit Message
* gnu/packages/bioinformatics.scm (umi-tools): Update to 1.1.6.
[source]: Switch to git-fetch.
[build-system]: Switch to pyproject-build-system.
[inputs]: Add python-pybktree, python-scipy.
[native-inputs]: Add python-setuptools, python-wheel.
---
gnu/packages/bioinformatics.scm | 18 +++++++++++-------
1 file changed, 11 insertions(+), 7 deletions(-)
@@ -21424,24 +21424,28 @@ (define-public checkm
(define-public umi-tools
(package
(name "umi-tools")
- (version "1.0.0")
+ (version "1.1.6")
(source
(origin
- (method url-fetch)
- (uri (pypi-uri "umi_tools" version))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/CGATOxford/UMI-tools")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
- (base32
- "08y3vz1vcx09whmbsn722lcs6jl9wyrh9i4p3k8j4cb1i32bij4a"))))
- (build-system python-build-system)
+ (base32 "1liykfj4msvcgk8an5qq802jcxwlijqxrvijipqj1pwpxqzl9qnh"))))
+ (build-system pyproject-build-system)
(inputs
(list python-pandas
python-future
python-scipy
python-matplotlib
python-regex
+ python-pybktree
+ python-scipy
python-pysam))
(native-inputs
- (list python-cython))
+ (list python-setuptools python-wheel))
(home-page "https://github.com/CGATOxford/UMI-tools")
(synopsis "Tools for analyzing unique modular identifiers")
(description "This package provides tools for dealing with @dfn{Unique