[bug#77400,17/26] gnu: Add python-pybktree.

Message ID 20250331061901.22670-17-ngraves@ngraves.fr
State New
Headers
Series Some further updates |

Commit Message

Nicolas Graves March 31, 2025, 6:18 a.m. UTC
  * gnu/packages/backup.scm (python-pybktree): New variable.
---
 gnu/packages/python-xyz.scm | 19 +++++++++++++++++++
 1 file changed, 19 insertions(+)
  

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index e57c834ddb..ba6a96f714 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -28939,6 +28939,25 @@  (define-public python-pybloom-live
 Python.")
     (license license:expat)))
 
+(define-public python-pybktree
+  (package
+    (name "python-pybktree")
+    (version "1.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "pybktree" version))
+       (sha256
+        (base32 "0asd2lw9c5l5wi4z24k7gkhlprpdkcvs8d94szk56x9xvmy07h7f"))))
+    (build-system pyproject-build-system)
+    (native-inputs (list python-setuptools python-wheel))
+    (home-page "https://github.com/Jetsetter/pybktree")
+    (synopsis "Pythonic BK-tree data structure")
+    (description
+     "This package provides a BK-tree data structure to allow fast querying of
+close matches in Python.")
+    (license license:expat)))
+
 (define-public python-pybtex
   (package
     (name "python-pybtex")