[bug#77400,11/26] gnu: seqmagick: Update to 0.8.6-0.dee6ab9.

Message ID 20250331061901.22670-11-ngraves@ngraves.fr
State New
Headers
Series Some further updates |

Commit Message

Nicolas Graves March 31, 2025, 6:18 a.m. UTC
  * gnu/packages/bioinformatics.scm (seqmagick): Update to 0.8.6-0.dee6ab9.
---
 gnu/packages/bioinformatics.scm | 44 ++++++++++++++++++---------------
 1 file changed, 24 insertions(+), 20 deletions(-)
  

Patch

diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 1351a15529..00f0e10475 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -12061,30 +12061,34 @@  (define-public seqan-1
        ("bzip2" ,bzip2)))))
 
 (define-public seqmagick
-  (package
-    (name "seqmagick")
-    (version "0.8.4")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (pypi-uri "seqmagick" version))
-       (sha256
-        (base32
-         "0c6skyig8fyylnbj4597pjj9h0dn36rkxrhwd34yrsc6k6f7r8a0"))))
-    (build-system pyproject-build-system)
-    (inputs
-     (list python-biopython python-pygtrie))
-    (native-inputs
-     (list python-pytest python-setuptools python-wheel))
-    (home-page "https://github.com/fhcrc/seqmagick")
-    (synopsis "Tools for converting and modifying sequence files")
-    (description
-     "Bioinformaticians often have to convert sequence files between formats
+  (let ((commit "dee6ab9839cff317142e55678bb12c4c9ab2150f")
+        (revision "0"))
+    (package
+      (name "seqmagick")
+      (version (git-version "0.8.6" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/fhcrc/seqmagick")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "0syipb7m44s5bqrhs17bwr28svy2s83j8d93kbazav92jzszzsw4"))))
+      (build-system pyproject-build-system)
+      (inputs
+       (list python-biopython python-pygtrie))
+      (native-inputs
+       (list python-nose python-setuptools python-wheel))
+      (home-page "https://github.com/fhcrc/seqmagick")
+      (synopsis "Tools for converting and modifying sequence files")
+      (description
+       "Bioinformaticians often have to convert sequence files between formats
 and do little manipulations on them, and it's not worth writing scripts for
 that.  Seqmagick is a utility to expose the file format conversion in
 BioPython in a convenient way.  Instead of having a big mess of scripts, there
 is one that takes arguments.")
-    (license license:gpl3)))
+      (license license:gpl3))))
 
 (define-public seqtk
   (package