[bug#77400,10/26] gnu: rseqc: Switch to pyproject-build-system.

Message ID 20250331061901.22670-10-ngraves@ngraves.fr
State New
Headers
Series Some further updates |

Commit Message

Nicolas Graves March 31, 2025, 6:18 a.m. UTC
  * gnu/packages/bioinformatics.scm (rseqc):
[build-system]: Switch to pyproject-build-system.
[inputs]: Sort inputs. Add python-pyparsing, python-setuptools,
python-wheel.
---
 gnu/packages/bioinformatics.scm | 13 ++++++++-----
 1 file changed, 8 insertions(+), 5 deletions(-)
  

Patch

diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 659e7cfea0..1351a15529 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -10828,13 +10828,16 @@  (define-public rseqc
        (sha256
         (base32
          "0gbb9iyb7swiv5455fm5rg98r7l6qn27v564yllqjd574hncpx6m"))))
-    (build-system python-build-system)
+    (build-system pyproject-build-system)
     (inputs
-     (list python-cython
-           python-bx-python
-           python-pybigwig
-           python-pysam
+     (list python-bx-python
+           python-cython
            python-numpy
+           python-pybigwig
+           python-pyparsing
+           python-pysam
+           python-setuptools
+           python-wheel
            zlib))
     (native-inputs
      (list python-nose))