[bug#77385] gnu: hdf-java: Update to 1.14.3.

Message ID 20250330141257.18074-1-david.elsing@posteo.net
State New
Headers
Series [bug#77385] gnu: hdf-java: Update to 1.14.3. |

Commit Message

David Elsing March 30, 2025, 2:12 p.m. UTC
  * gnu/packages/maths.scm (hdf-java): Update to 1.14.3.
[arguments]: Adjust dependency versions in 'unbundle phase.
[inputs]: Replace hdf5 with hdf5-1.14.
[home-page]: Update.
[license]: Update URL.

Change-Id: I43db316c3a83f5ddac14b0c670430811dcac6bdc
---
 gnu/packages/maths.scm | 18 +++++++++---------
 1 file changed, 9 insertions(+), 9 deletions(-)
  

Comments

Andreas Enge March 31, 2025, 8:29 a.m. UTC | #1
Excellent, thanks a lot! I made the error of not realising that
(find-files "java" "Makefile.am")
traversed subdirectories, where the substitutes occur.

I am going to push this as part of https://issues.guix.gnu.org/77287
and close this issue.

Andreas
  

Patch

diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 3de5b7b8ae..d47c3425af 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -1880,7 +1880,7 @@  (define-public hdf5
 (define-public hdf-java
   (package
     (name "hdf-java")
-    (version "1.10.9")
+    (version "1.14.3")
     (source
      (origin
        (method git-fetch)
@@ -1892,7 +1892,7 @@  (define-public hdf-java
                                      version)))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "1sjdcnafvzsy99vqhybkps8rnwmxb6fsvmkw89wb2mrrp4vi5z9v"))
+        (base32 "0lw9f62zxyjiv7vx9nvnashjj39i44j8d626i7b788zkxw58csvs"))
        (modules '((guix build utils)))
        (snippet     ; Make sure we don't use the bundled sources and binaries.
         '(for-each delete-file
@@ -1921,9 +1921,9 @@  (define-public hdf-java
                       inputs "/lib/m2/org/hamcrest/hamcrest-core/1.3/hamcrest-core-1.3.jar")))
                 (substitute* (append (find-files "java" "Makefile.am")
                                      (find-files "java" "Makefile.in"))
-                  (("\\$\\(top_srcdir\\)/java/lib/ext/slf4j-simple-1.7.33.jar")
+                  (("\\$\\(top_srcdir\\)/java/lib/ext/slf4j-simple-2.0.6.jar")
                    simple)
-                  (("\\$\\(top_srcdir\\)/java/lib/slf4j-api-1.7.33.jar")
+                  (("\\$\\(top_srcdir\\)/java/lib/slf4j-api-2.0.6.jar")
                    api)
                   (("\\$\\(top_srcdir\\)/java/lib/junit.jar")
                    junit)
@@ -1944,9 +1944,9 @@  (define-public hdf-java
                    junit)
                   (("\"\\$BLDLIBDIR\"/hamcrest-core.jar")
                    hamcrest)
-                  (("\"\\$BLDLIBDIR\"/slf4j-api-1.7.33.jar")
+                  (("\"\\$BLDLIBDIR\"/slf4j-api-2.0.6.jar")
                    api)
-                  (("\"\\$BLDLIBDIR\"/slf4j-simple-1.7.33.jar")
+                  (("\"\\$BLDLIBDIR\"/slf4j-simple-2.0.6.jar")
                    simple)
                   (("/usr/bin/test")
                    (search-input-file inputs "/bin/test"))
@@ -1963,11 +1963,11 @@  (define-public hdf-java
            java-slf4j-simple))
     (inputs
      (list hdf4
-           hdf5
+           hdf5-1.14
            java-slf4j-api
            libjpeg-turbo
            zlib))
-    (home-page "https://support.hdfgroup.org/products/java")
+    (home-page "https://www.hdfgroup.org")
     (synopsis "Java interface for the HDF4 and HDF5 libraries")
     (description "Java HDF Interface (JHI) and Java HDF5 Interface (JHI5) use
 the Java Native Interface to wrap the HDF4 and HDF5 libraries, which are
@@ -1976,7 +1976,7 @@  (define-public hdf-java
     ;; BSD-style license:
     (license (license:x11-style
               "https://support.hdfgroup.org/ftp/HDF5/hdf-java\
-/current/src/unpacked/COPYING"))))
+/current/src/unpacked/COPYING.html"))))
 
 (define-public hdf-eos2
   (package