[bug#77379,1/2] gnu: font-tamzen: Update to 1.11.6

Message ID 20250330041443.31578-1-hunt31999@gmail.com
State New
Headers
Series gnu: font-tamzen: Update to 1.11.6 |

Commit Message

Kurome March 30, 2025, 4:14 a.m. UTC
  Change-Id: Icaad387814dc101c6a84c755535ac714103d275f
---
 gnu/packages/fonts.scm | 32 +++++++-------------------------
 1 file changed, 7 insertions(+), 25 deletions(-)
  

Patch

diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index 9c7f50a838..6e6ea39172 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -1810,36 +1810,17 @@  (define-public font-awesome
 (define-public font-tamzen
   (package
     (name "font-tamzen")
-    (version "1.11.5")
+    (version "1.11.6")
     (source
      (origin
        (method git-fetch)
        (uri (git-reference
-              (url "https://github.com/sunaku/tamzen-font")
-              (commit (string-append "Tamzen-" version))))
+             (url "https://github.com/sunaku/tamzen-font")
+             (commit (string-append "Tamzen-" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "00x5fipzqimglvshhqwycdhaqslbvn3rl06jnswhyxfvz16ymj7s"))))
-    (build-system trivial-build-system)
-    (arguments
-     `(#:modules ((guix build utils))
-       #:builder
-       (begin
-         (use-modules (guix build utils))
-
-         (let* ((out      (assoc-ref %outputs "out"))
-                (font-dir (string-append out "/share/fonts/misc"))
-                (psf-dir  (string-append out "/share/kbd/consolefonts")))
-           (chdir (assoc-ref %build-inputs "source"))
-           (mkdir-p font-dir)
-           (mkdir-p psf-dir)
-           (for-each (lambda (pcf)
-                       (install-file pcf font-dir))
-                     (find-files "pcf" "\\.pcf$"))
-           (for-each (lambda (psf)
-                       (install-file psf psf-dir))
-                     (find-files "psf" "\\.psf$"))
-           #t))))
+        (base32 "1lmb50rdna549dv64whb1ilff324ivz9cxlrdkf3r9vbdsram5av"))))
+    (build-system font-build-system)
     (home-page "https://github.com/sunaku/tamzen-font")
     (synopsis "Monospaced bitmap font for console and X11")
     (description
@@ -1857,7 +1838,8 @@  (define-public font-tamzen
 @item the branch of the fork icon ( U+E0A0) was made larger than the trunk
 @item for the newline icon ( U+E0A1), the @emph{N} was made larger at the bottom
 @item the keyhole in the padlock icon ( U+E0A2) was replaced with @emph{//} lines.
-@end enumerate\n")
+@end enumerate
+")
     (license (license:non-copyleft "file://LICENSE"))))
 
 (define-public font-comic-neue