[bug#77356,v2] Update font-sarasa-gothic to 1.0.29

Message ID 20250329122736.19951-2-hunt31999@gmail.com
State New
Headers
Series [bug#77356,v2] Update font-sarasa-gothic to 1.0.29 |

Commit Message

Kurome March 29, 2025, 12:26 p.m. UTC
  I ran `guix style`.

Change-Id: Ica9f966b5bb0b0db69e240800394a0ea3f16531f
---
 gnu/packages/fonts.scm | 25 +++++++++++++++----------
 1 file changed, 15 insertions(+), 10 deletions(-)
  

Comments

Zheng Junjie March 30, 2025, 3:30 a.m. UTC | #1
Kurome <hunt31999@gmail.com> writes:

> I ran `guix style`.
>

commit message should like this:
```
gnu: font-sarasa-gothic: update to 1.0.29.

* gnu/packages/fonts.scm (font-sarasa-gothic): Update to 1.0.29.
[arguments]: Use G-expressions.
```

> Change-Id: Ica9f966b5bb0b0db69e240800394a0ea3f16531f
> ---
>  gnu/packages/fonts.scm | 25 +++++++++++++++----------
>  1 file changed, 15 insertions(+), 10 deletions(-)
>
> diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
> index cadc62d7d7..04bd08bac7 100644
> --- a/gnu/packages/fonts.scm
> +++ b/gnu/packages/fonts.scm
> @@ -2417,23 +2417,28 @@ (define-public font-junicode
>  (define-public font-sarasa-gothic
>    (package
>      (name "font-sarasa-gothic")
> -    (version "1.0.27")
> +    (version "1.0.29")
>      (source
>       (origin
>         (method url-fetch)
>         (uri (string-append "https://github.com/be5invis/Sarasa-Gothic"
> -                           "/releases/download/v" version
> -                           "/Sarasa-TTC-" version ".7z"))
> +                           "/releases/download/v"
> +                           version
> +                           "/Sarasa-TTC-"
> +                           version
> +                           ".7z"))
>         (sha256
> -        (base32 "19k11nl6sib8ms82jvvv23543p4xdzybgfflz2jxjim55w9d1v4y"))))
> +        (base32 "1y82wp3rgm1xnn92f0jppgiqjsimdy83ljyh5q9dybzx3fp0x8w7"))))
>      (build-system font-build-system)
>      (arguments
> -     `(#:phases (modify-phases %standard-phases
> -                  (replace 'unpack
> -                    (lambda* (#:key source #:allow-other-keys)
> -                      (mkdir "source")
> -                      (chdir "source")
> -                      (invoke "7z" "x" source))))))
> +     (list
> +      #:phases
> +      #~(modify-phases %standard-phases
> +          (replace 'unpack
> +            (lambda* (#:key source #:allow-other-keys)
> +              (mkdir "source")
> +              (chdir "source")
> +              (invoke "7z" "x" source))))))
>      (native-inputs (list p7zip))
>      (home-page "https://github.com/be5invis/Sarasa-Gothic")
>      (license license:silofl1.1)
pushed, closing.
  

Patch

diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index cadc62d7d7..04bd08bac7 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -2417,23 +2417,28 @@  (define-public font-junicode
 (define-public font-sarasa-gothic
   (package
     (name "font-sarasa-gothic")
-    (version "1.0.27")
+    (version "1.0.29")
     (source
      (origin
        (method url-fetch)
        (uri (string-append "https://github.com/be5invis/Sarasa-Gothic"
-                           "/releases/download/v" version
-                           "/Sarasa-TTC-" version ".7z"))
+                           "/releases/download/v"
+                           version
+                           "/Sarasa-TTC-"
+                           version
+                           ".7z"))
        (sha256
-        (base32 "19k11nl6sib8ms82jvvv23543p4xdzybgfflz2jxjim55w9d1v4y"))))
+        (base32 "1y82wp3rgm1xnn92f0jppgiqjsimdy83ljyh5q9dybzx3fp0x8w7"))))
     (build-system font-build-system)
     (arguments
-     `(#:phases (modify-phases %standard-phases
-                  (replace 'unpack
-                    (lambda* (#:key source #:allow-other-keys)
-                      (mkdir "source")
-                      (chdir "source")
-                      (invoke "7z" "x" source))))))
+     (list
+      #:phases
+      #~(modify-phases %standard-phases
+          (replace 'unpack
+            (lambda* (#:key source #:allow-other-keys)
+              (mkdir "source")
+              (chdir "source")
+              (invoke "7z" "x" source))))))
     (native-inputs (list p7zip))
     (home-page "https://github.com/be5invis/Sarasa-Gothic")
     (license license:silofl1.1)