[bug#77040,v4,05/12] gnu: Add rust-colored-3.
Commit Message
* gnu/packages/crates-io.scm (rust-colored-3): New variable.
* gnu/packages/crates-io.scm (rust-colored-2): Inherit from
rust-colored-3.
Change-Id: Ie78a8701fb294f8d582eb3a6865d1a7d0772b9ad
---
gnu/packages/crates-io.scm | 48 +++++++++++++++++++++++++++-----------
1 file changed, 34 insertions(+), 14 deletions(-)
@@ -14069,19 +14069,44 @@ (define-public rust-colorchoice-1
(description "Global override of color control")
(license (list license:expat license:asl2.0))))
+(define-public rust-colored-3
+ (package
+ (name "rust-colored")
+ (version "3.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "colored" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "0plizddhxc4vgkzdbzky5zggyaqfrmyim2d0n6sb7py9j3nf1q7x"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:tests? #f ; Tests expect a real terminal.
+ #:cargo-inputs
+ (("rust-windows-sys" ,rust-windows-sys-0.59)
+ ("rust-ansi-term" ,rust-ansi-term-0.12)
+ ("rust-insta" ,rust-insta-1.42)
+ ("rust-rspec" ,rust-rspec-1))))
+ (home-page "https://github.com/mackwic/colored")
+ (synopsis "Add colors in your terminal")
+ (description
+ "The most simple way to add colors in your terminal.")
+ (license license:mpl2.0)))
+
(define-public rust-colored-2
(package
+ (inherit rust-colored-3)
(name "rust-colored")
(version "2.1.0")
(source
- (origin
- (method url-fetch)
- (uri (crate-uri "colored" version))
- (file-name (string-append name "-" version ".tar.gz"))
- (sha256
- (base32
- "1f4h9p64snrnz4x432iza15p4diqjcgpmpvhi956d6r1rq61bwnb"))))
- (build-system cargo-build-system)
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "colored" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1f4h9p64snrnz4x432iza15p4diqjcgpmpvhi956d6r1rq61bwnb"))))
(arguments
`(#:tests? #f
#:cargo-inputs
@@ -14089,12 +14114,7 @@ (define-public rust-colored-2
("rust-windows-sys" ,rust-windows-sys-0.48))
#:cargo-development-inputs
(("rust-ansi-term" ,rust-ansi-term-0.12)
- ("rust-rspec" ,rust-rspec-1.0.0-beta.3))))
- (home-page "https://github.com/mackwic/colored")
- (synopsis "Add colors in your terminal")
- (description
- "The most simple way to add colors in your terminal.")
- (license license:mpl2.0)))
+ ("rust-rspec" ,rust-rspec-1.0.0-beta.3))))))
(define-public rust-colored-1
(package